Development


uiWebPrevious123uiWebNext

#16 [en] 

Lopyrech
I'm fine with 1 equip time (requires no change server-side), in reality it takes around 3-5 seconds max to change jewels or armor (armor being faster), so 2 equip time for an item set seems fine (that's 10 seconds if you change armor)

Hmmm... it takes me 10-15 seconds (jewels plus armor) *plus* the last load cycle, which fits very well with my 3-5 cycles estimate earlier. Ten seconds is still not long enough in my opinion.

Mjollren -- Two of your examples involve PvP where I already acknowledged the usefulness of it.

The other two involve cases where, under the current situation you can hit MPA and change armor (or just run away), so it's only a matter of convenience and I will continue to hold that it ought to take time. The game is balanced.

I have already said I like the convenience. We don't need super-speed to go with the convenience.

---


Remembering Tyneetryk
Phaedreas Tears - 15 years old and first(*) of true neutral guilds in Atys.
(*) This statement is contested, but we are certainly the longest lasting.
<clowns | me & you | jokers>

#17 [en] 

Siela
The compiled client with changes for Mac is now available, check link in Lopyrech's post.
You just have to copy the data folder from your normal Ryzom install (right-click on the program -> show package contents -> Contents -> Resources -> data) to the downloaded Ryzom, to the same place. The files mentioned in Lopyrechs post (widgets.xml and commands.xml) need to be copied to /Users/<user>/Library/Application Support/Ryzom/user folder. Have fun testing it out :D If you have any questions contact me.

I am too scared to do this let alone understand it, lol. I am afraid i will mess up my client if i try. I think i need a little hand-holding :(

#18 [en] 

It tells me I need OS X 10.12 installed, I only have OS X 10.11.6 ^^
Siela, thank you for compiling anyway, I would not try to do that myself :)

#19 [fr] 

This works on live server ?

#20 Multilingual 

Multilingual | [English] | Fran├žais
General upgrades, and added a windows client who will hopefully work (thanks to osquallo for helping me set up a windows build env !), see first post.


@Gersen: Yes !

Last edited by Lopyrech (3 years ago)

---

#21 Multilingual 

This is what I did for windows client:

1. Downloaded the client and the two xml files.
2. Copy the above files to its proper location.
3. Run the new client (didn't work asking for fmod.dll file)
3. Rename my old client then rename the new client to ryzom_client_r.exe and run (it still ask for fmod.dll file)
4. Run my old client (it runs and also update ryzom_client_r.exe.
5. Close Ryzom then run ryzom_client_r.exe (It runs but the createGroup command is unknown even naked command hehehehe.

When I right click on any items in my inventory it still displays (<NotExist:uimGroup>) as one of the choices.

So far I was not able to test it in windows I am using Windows 10.

Last edited by Afriel (3 years ago)

---

#22 Multilingual 

This is what I did for Mac Sierra:

1. Download the new client and the two xml files.
2. Locate my old client (in application folder) right click then select show package content. Double click contents folder then right click Resources then select copy).
3. Right click my new downloaded client then select show package content. Double click contents then paste. It will inform you that resources folder is already inside, continue and select replace everything.
4. Copy the two xml files to its proper location.
5. Run the new downloaded client.

It is working so far

---

#23 [en] 

Afriel
This is what I did for windows client:

1. Downloaded the client and the two xml files.
2. Copy the above files to its proper location.
3. Run the new client (didn't work asking for fmod.dll file)
3. Rename my old client then rename the new client to ryzom_client_r.exe and run (it still ask for fmod.dll file)
4. Run my old client (it runs and also update ryzom_client_r.exe.
5. Close Ryzom then run ryzom_client_r.exe (It runs but the createGroup command is unknown even naked command hehehehe.

When I right click on any items in my inventory it still displays (<NotExist:uimGroup>) as one of the choices.

So far I was not able to test it in windows I am using Windows 10.

If you rename it to ryzom_client_r.exe, at launch the client will see that the file ryzom_client_r.exe needs to be patched and it will replace it. You need to keep a different name (like ryzom_client_glorf), and launch this one (directly if you don't use installer, or by selecting a different excutable if you use installer)

---

#24 [en] 

Lopyrech
If you rename it to ryzom_client_r.exe, at launch the client will see that the file ryzom_client_r.exe needs to be patched and it will replace it. You need to keep a different name (like ryzom_client_glorf), and launch this one (directly if you don't use installer, or by selecting a different excutable if you use installer)

I run it as ryzom_client_glorf.exe but it ask me for fmod.dll file it says it is missing. Next, I rename it to ryzom_client_r.exe and run still it gives me same error. Then I run the old ryzom client it runs but this time it also updated my ryzom_client_r.exe. I close my old ryzom client then open the ryzom_client_r.exe it runs but it did not recognize the item group commands.

---

#25 [en] 

Afriel
Lopyrech
If you rename it to ryzom_client_r.exe, at launch the client will see that the file ryzom_client_r.exe needs to be patched and it will replace it. You need to keep a different name (like ryzom_client_glorf), and launch this one (directly if you don't use installer, or by selecting a different excutable if you use installer)

I run it as ryzom_client_glorf.exe but it ask me for fmod.dll file it says it is missing. Next, I rename it to ryzom_client_r.exe and run still it gives me same error. Then I run the old ryzom client it runs but this time it also updated my ryzom_client_r.exe. I close my old ryzom client then open the ryzom_client_r.exe it runs but it did not recognize the item group commands.

Can you try This one without renaming it ?
It's strange you have a fmod error, what's your ryzom setup (installer or launching it directly) ? Do you have a file name nel_drv_fmod_win_r.dll in your ryzom folder (where the client is) ?

---

#26 [en] 

Lopyrech
Can you try This one without renaming it ?
It's strange you have a fmod error, what's your ryzom setup (installer or launching it directly) ? Do you have a file name nel_drv_fmod_win_r.dll in your ryzom folder (where the client is) ?

Yehey this one works for me. I tried to integrate <remove slot="head"/> but it didn't work. I notice that the file group_myname.xml will rebirth to its original state before I put <remove slot="head"/> meaning it is gone when I open it again.

---

#27 [en] 

Afriel
Lopyrech
Can you try This one without renaming it ?
It's strange you have a fmod error, what's your ryzom setup (installer or launching it directly) ? Do you have a file name nel_drv_fmod_win_r.dll in your ryzom folder (where the client is) ?

Yehey this one works for me. I tried to integrate <remove slot="head"/> but it didn't work. I notice that the file group_myname.xml will rebirth to its original state before I put <remove slot="head"/> meaning it is gone when I open it again.

You n,eed to change the group.xml with the game not running (same asthe keys.xml file)

---

#28 [en] 

Lopyrech
Afriel
Lopyrech
Can you try This one without renaming it ?
It's strange you have a fmod error, what's your ryzom setup (installer or launching it directly) ? Do you have a file name nel_drv_fmod_win_r.dll in your ryzom folder (where the client is) ?

Yehey this one works for me. I tried to integrate <remove slot="head"/> but it didn't work. I notice that the file group_myname.xml will rebirth to its original state before I put <remove slot="head"/> meaning it is gone when I open it again.

You n,eed to change the group.xml with the game not running (same asthe keys.xml file)

Yes, I did it while ryzom is not running although I am using mac at that time. I will try windows and see what will happen, Yehey it works on windows. I will try later in my mac. It didn't work, after you quit ryzom it will update group_myname.xml it will remove <remove slot="head"/>. Also I notice and error in windows when you quit it says access denied to write something in virtual memory, it only happens when you put <remove slot="head"/>.

Edited 2 times | Last edited by Afriel (3 years ago)

---

#29 [en] 

Afriel
Lopyrech
Afriel
Lopyrech
Can you try This one without renaming it ?
It's strange you have a fmod error, what's your ryzom setup (installer or launching it directly) ? Do you have a file name nel_drv_fmod_win_r.dll in your ryzom folder (where the client is) ?

Yehey this one works for me. I tried to integrate <remove slot="head"/> but it didn't work. I notice that the file group_myname.xml will rebirth to its original state before I put <remove slot="head"/> meaning it is gone when I open it again.

You n,eed to change the group.xml with the game not running (same asthe keys.xml file)

Yes, I did it while ryzom is not running although I am using mac at that time. I will try windows and see what will happen, Yehey it works on windows. I will try later in my mac. It didn't work, after you quit ryzom it will update group_myname.xml it will remove <remove slot="head"/>. Also I notice and error in windows when you quit it says access denied to write something in virtual memory, it only happens when you put <remove slot="head"/>.

I updated the client, can you check now ? (ryzom_client_glorf.exe is now without fmod until I find out why it isn't here everywhere)

---

#30 Multilingual 

Both Mac and Windows are now working. Thank you very much.

---

uiWebPrevious123uiWebNext
 
Last visit Tue Aug 4 20:42:11 2020 UTC
P_:

powered by ryzom-api