English French German Spanish Russian
Version 3.0 - Disconnects Disconnects Disconnets - TECHNICAL SUPPORT / WEB APPs BUGS - Ryzom Community ForumHomeGuest

TECHNICAL SUPPORT / WEB APPs BUGS


uiWebPrevious123uiWebNext

#1 Report | Quote[en] 

I have the best internet connection I can get. It's stable beyond stable. It rarely goes out. I run two desktop machines side-by-side, both reasonably up to date. Both run with nVidia cards.

Prior to v.3 I had little trouble with disconnects anywhere. During PW O'Clock, it was laggy, but it didn't generally boot me out of game.

Now, with this version, I get random disconnects on both machines, sometimes at the same time. The game just freezes. It isn't in cities, it isn't in particular regions, it isn't in apartments. It's only in this game, because I don't have this trouble in other games.

What can I do to resolve this? I play Ryzom a lot but I am getting really annoyed.

Yes I'm using the installer, but as an aside, if you have an SSD drive as your main drive, this new installer writes to the main drive, which is the last place you would want it to write to.

---

Sassafras


#2 Report | Quote[en] 

Same troubles yesterday, disconnect, disconnect...
I decided to wait maybe tomorrow soll be better ?

---

#3 Report | Quote[en] 

I can recommend not using the installer and copying the full installation from the SSD to a regular HDD so that you have the advantage of not having to go through the controller of the SSD. I have been running Ver. 3 and have no problems even when I am running side by side clients on my one computer.

I strongly suspect it is the use of AppData on your SSD for things like Save files that is causing the problems.

(My system: Win 7 Home, Premium Athlon II x 2 3.0 GHz, Nvidia GeForce GTX 560 Ti) -- Not a super-system by any means.

---


Remembering Tyneetryk
Phaedreas Tears - 13 years old and first(*) of true neutral guilds in Atys.
(*) This statement is contested, but we are certainly the longest lasting.
<clowns | me & you | jokers>

#4 Report | Quote[en] 

Annnnnnnnd once again patch day.

Every time they make a patch I can't connect for hours. My system crashes. I edit files. I ask questions. I come to the forums.

How many new players are going to edit their text files. Over and over write letters to support, go to irc channel, go through megacorp or any of other multitude of things we try to connect.

Even the usual 750 millions times we have to redo the patch over and over. How many new players or even old players are going to keep paying for and trying to connect to a game they can't play?

Surely there is some way they could test a patch before forcing players to install it in order to connect. Which I can't do again.

#5 Report | Quote[en] 

Nume
Every time they make a patch I can't connect for hours. My system crashes. I edit files. I ask questions. I come to the forums.
Can you describe what the problems you experiencing?

'system crashes' unfortunately is not useful.

What files you need to edit to get it running again?
What system you using? Linux? Window? Xp/7/10? macOS?
Where is ryzom installed?
Do you use ryzom installer or a custom one?
Does patch hang and you need to kill it from task manager or such

Having some of the answers may help determine why you having problems while others don't.
It may also help to try to replicate the problem so it could be fixed.

---

Hello!

#6 Report | Quote[en] 

I have posted the more complete information here.

How to fix the Ryzom Patch.

I am sorry. I do not mean to be violating the Code of conduct by posting in more than one place.

I am using Linux Mint Rosa 17.3 on a 64 bit PC with dual core. Optiplex 755 with 3 gig of Ram.

Ryzom was originally installed in the /home/user/.ryzom directory.

I made a copy to /home/user/.local/share/Ryzom

Each time I start the game I have to go into /home/user/.ryzom and right click on ryzom_client. The reason being for that is I had installed Steam previously and the launch icon (even when I have made the shortcut from inside the .ryzom folder) defaults to the Steam client. So, I have to start the native ryzom client from inside .ryzom.

I have had to edit client_default.cfg. That is to change "Auto" to 1 for OpenGL. Which at the end of every patch gets rewrote back to Auto.

The patch does not hang. The patch crashes. Apparently from not being able to find the file it is looking for.

Edited 2 times | Last edited by Nume (2 years ago)

#7 Report | Quote[en] 

This is the latest nel report from trying to start it in the .ryzom folder.

Reason: SERVICE: Neither the config file '/home/user/.ryzom/patch_gen_service.cfg' nor the default one can be found, can't launch the service
-------------------------------

Log with no filter:
-------------------------------

Log Starting [2016/09/25 18:59:29]
2016/09/25 18:59:29 <Unknown> INF 0a5b8780 command.cpp 149 : CCommandRegistry : adding commands handler for class 'CModuleManager'
2016/09/25 18:59:29 <Unknown> INF 0a5b8780 module_manager.cpp 228 : Adding module 'LocalGateway' factory
2016/09/25 18:59:29 <Unknown> INF 0a5b8780 module_manager.cpp 228 : Adding module 'StandardGateway' factory
2016/09/25 18:59:29 PGS INF 0a5b8780 service.cpp 248 : SERVICE: 'ConfigDirectory' changed to '/home/user/.ryzom/'
2016/09/25 18:59:29 PGS INF 0a5b8780 service.cpp 248 : SERVICE: 'LogDirectory' changed to '/home/user/.ryzom/'
2016/09/25 18:59:29 PGS ERR 0a5b8780 service.cpp 620 : SERVICE: Neither the config file '/home/user/.ryzom/patch_gen_service.cfg' nor the default one can be found, can't launch the service

In my .ryzom folder I have patch_gen and patch_gen_service. I do not have the file patch_gen_service.cfg.

Last edited by Nume (2 years ago)

#8 Report | Quote[en] 

Nume
Each time I start the game I have to go into /home/user/.ryzom and right click on ryzom_client. The reason being for that is I had installed Steam previously and the launch icon (even when I have made the shortcut from inside the .ryzom folder) defaults to the Steam client. So, I have to start the native ryzom client from inside .ryzom.

You need to remove old ryzom icon or menu item. Make sure steam does not recreate it. Then you should be able to recreate icon.
If you running from custom directory (.ryzom under home), then make sure ryzom_client and ryzom_configuraton_qt active directory is set to /home/user/.ryzom (avoid ~ shortcut for home)

You can run ryzom_client from any directory you want, but in that case, client makes /home/user/.local/share/Ryzom folder automatically to hold user specific stuff (config, keys, screenshots, etc).

Ryzom does not use /home/user/.ryzom anymore and defaults are:
/home/user/.local/share/Ryzom/ryzom_live -- program files and data
/home/user/.local/share/Ryzom/0 - user specific stuff when using '-p 0' argument for ryzom_client

And if you forgot the -p 0 argument, then user files can be found in /home/user/.local/share/Ryzom

Sounds complicated, but ryzom_installer_qt is used to manage and hide all that from user.

Nume
I have had to edit client_default.cfg. That is to change "Auto" to 1 for OpenGL. Which at the end of every patch gets rewrote back to Auto.
Use ryzom_configuration_qt to make out of game changes (game must be closed).

---

Hello!

#9 Report | Quote[en] 

Nume
This is the latest nel report from trying to start it in the .ryzom folder.

Reason: SERVICE: Neither the config file '/home/user/.ryzom/patch_gen_service.cfg' nor the default one can be found, can't launch the service

You seem to be running patch_gen_service program. It's not included with client.
If you running ryzom_client and getting that error, then something is very wrong.

Ryzom client only has:
ryzom_client
ryzom_client_patcher
ryzom_configuration_qt
ryzom_installer_qt

---

Hello!

#10 Report | Quote[en] 

Thank you for your help Karu.

I deleted the folder I had made in /home/.local/share/Ryzom that was identical to the contents I had in /home/user/.ryzom and renamed the ryzombak folder I had to Ryzom again in /home/user/.local/share

I checked the path for the that ryzom_installer_qt is using. It is using /home/user/.ryzom.

I reran the patch and crashed at 63% if I remember correctly.

I then read your latest post Karu.
"Karu"
You seem to be running patch_gen_service program. It's not included with client.
If you running ryzom_client and getting that error, then something is very wrong.

Ryzom client only has:
ryzom_client
ryzom_client_patcher
ryzom_configuration_qt
ryzom_installer_qt

I am running ryzom_client.

Now what do I do?

Edited 2 times | Last edited by Nume (2 years ago)

#11 Report | Quote[en] 

I just tried to start Ryzom with the Steam client. It crashed at approximately 63%.

I also tried to start from the Ryzom desktop launcher. That also crashed. It came up with a default name that I should have copied down but didn't that was something like:

Programs/ember_dll64 something close to that. Which seems to be trying to use Wine to run Ryzom as a windows program.

#12 Report | Quote[en] 

Just sticking a questioning ear in here: I'm wondering if you are getting upgrades to the Windoz version of the client somehow?

I'm wondering because of your comments about Wine.

I have had zero problems in Win 7 with the new clients. I'll need to fire up my Linux box and see if the same applies there.

---


Remembering Tyneetryk
Phaedreas Tears - 13 years old and first(*) of true neutral guilds in Atys.
(*) This statement is contested, but we are certainly the longest lasting.
<clowns | me & you | jokers>

#13 Report | Quote[en] 

Why do you need to edit CLIENT_DEFAULT.CFG to use OpenGL under LINUX ? oO

OpenGL is ALWAYS the default driver under Linux and OS X (and even under Windows).

And about missing "patch_gen_service.cfg" it means that you're running "patch_gen_service" executable... So you have a patch server on your computer ? Oo

And under Linux, you'll download exedll_win64_.ref and exedll_win32_.ref, that's normal and don't worry, it won't use Windows versions of the client but that's just related to patch system.

---

Kervala - Ryzom volunteer developer - Working on different clients

#14 Report | Quote[en] 

Nume
I am running ryzom_client.

Now what do I do?
ryzom_client file is about 30MB, patch_gen_service is about 2MB.

If you really do have patch_gen_service renamed as ryzom_client for some reason, then get new archive from
ryzom.kervala.net under 'Latest static clients' section (64bit linux I suppose). Do not use Steam version of client.

You should clean /home/user/.local/share/Ryzom from old files by moving them to 'ryzom_old' directory for example.
You need 'data', 'save' folders from there later.

After you downloaded client archive, then unpack it to /home/user/.local/share/Ryzom/ryzom_live
Make these files executable ('chmod +x name' from command line)

./ryzom_client
./ryzom_client_patcher
./ryzom_configuration_qt
./ryzom_installer_qt

Then copy 'data' folder to /home/user/.local/share/Ryzom/ryzom_live
Now copy /home/user/.local/share/Ryzom/ryzom_live/ryzom_installer_qt to /home/user/.local/share/Ryzom and run it
from there (working directory does not matter).

You should see initial 'Welcome' screen, pressing 'OK' should be quick after which you should see changelog text and 'Play', 'Configure' buttons below.
Pressing 'play' should launch client, which should then patch after login.
After patch has restarted client, then exit it and you can copy over 'save' folder to /home/user/.local/share/Ryzom/0/
and also run 'configure' to set parameters.
On installer screen under 'settings/profile' menu, you can make desktop and menu shortcuts for client.

If you want to run configure later, then you must do so using ryzom_installer_qt (or use '-p 0' switch running configure, but installer app is eaier)

Ryzom Installer should be under menu (Games)
Nume
I just tried to start Ryzom with the Steam client. It crashed at approximately 63%.
client.log should have some info why it crashes.
Nume
Programs/ember_dll64 something close to that. Which seems to be trying to use Wine to run Ryzom as a windows program.
If you using windows version of Steam under linux, then Steam is installing windows version of Ryzom. Dll in question may be steam_dll64.dll

Unless you using Steam to login into Ryzom, then you do not need (or want) Ryzom under Steam and should uninstall it.
By default Steam is keeping files in its own path, so deleting from there does not delete /home/user/.local/Ryzom directory.

If you do use Steam to login into Ryzom, then you should use linux version of Steam.

---

Hello!

#15 Report | Quote[en] 

"Bitttymacod"
Just sticking a questioning ear in here: I'm wondering if you are getting upgrades to the Windoz version of the client somehow?

I'm not sure what the Steam client uses. I am with you Bittty I should not be getting Windoze updates. I have used Linux since 2001. I am careful to get the Linux 64 version. Linux is the only operating system I use.
"Xiombarg"
Why do you need to edit CLIENT_DEFAULT.CFG to use OpenGL under LINUX ? oO

OpenGL is ALWAYS the default driver under Linux and OS X (and even under Windows).

And about missing "patch_gen_service.cfg" it means that you're running "patch_gen_service" executable... So you have a patch server on your computer ? Oo

I need to edit CLIENT_DEFAULT.CFG every time I patch or the patch fails. You would probably know the reason for that better than me. All I know is if it's on Auto the patch fails. If I put in "1" to make it use OpenGL then the patch works. I have had to do that for a couple of months now. I thought somewhere along the way a patch would fix that.

I have patch_gen 1.3 MB and patch_gen_service 2.5 MB and ryzom_client 32.8 MB in my .ryzom folder.

I start Ryzom by going into my /home/user/.ryzom folder and right clicking ryzom_client and telling it to open. Then on bad days I get THE PATCH. I have learned after the patch fails about three times and I tear my hair out and beat my chest that it is just easier to go into CLIENT_DEFAULT.CFG and change the Auto to 1. Then THE PATCH will work.
"Karu"
If you really do have patch_gen_service renamed as ryzom_client for some reason, then get new archive from
ryzom.kervala.net under 'Latest static clients' section (64bit linux I suppose). Do not use Steam version of client.

Karu your post is quite long. I am drinking coffee and just woke up. I am studying your post and debating reinstalling my whole OS and starting again from scratch. :(

Of course by saving what files I need to save. :(

Thank you everyone for your help. I will get back to you later today.

Last edited by Nume (2 years ago)

uiWebPrevious123uiWebNext
 
Last visit Sun Nov 18 16:33:58 2018 UTC
P_:

powered by ryzom-api