OFFICIAL NEWS


uiWebPrevious1uiWebNext

#1 Report | QuoteMultilingual 

Multilingual | English | [Français]

Tester la nouvelle version du client via le mode bêta dans RyZtart

Une mise à jour de Ryzom a été faite en appliquant les modifications récentes de Ryzom Core.
Ces modifications incluent de nombreux correctifs, mais peuvent amener également des bugs.Bien qu'ayant déjà testé une grande partie de ces modifications, il nous est très difficile de tester l'intégralité du jeu dans les mêmes conditions que sur Atys.

C'est pourquoi RyZtart se dote d'une option BETA-TEST, une simple case à cocher qui permet d'obtenir le patch du nouveau client avant tout le monde. De pouvoir ainsi tester et remonter d'éventuels bugs.
Pour revenir dans la version stable de Ryzom, il suffit de décocher la case beta-test.



Pour les joueurs sous MacOS, RyZtart n'étant pas encore disponible, vous pouvez contacter Ulukyn (https://chat.ryzom.com/direct/Ulukyn) qui vous indiquera la marche à suivre.

Vous pouvez reporter tout bug concernant cette mise à jour soit par ticket au Support, soit en répondant ci-dessous.

Edited 7 times | Last edited by Maupas (3 weeks ago) | Reason: Titles' typos

---

Tamarea
Ryzom Team Manager
(FR / EN / ES)

tamarea@ryzom.com

#2 Report | Quote[fr] 

Bugs reported

- FMod driver crash the client
- Classic titles can be applied, but encoding issues happens
- Special titles can't be applied

Bugs fixed

- A bug with teleport loading screens (texture are missing)
- A bug reset the whole interface if you talked to a player with a title containing non-ascii characters

Edited 8 times | Last edited by Ulukyn (3 weeks ago)

#3 Report | Quote[en] 

Beta 889

Hello,

* when I launched my client today all settings where reset (open windows on desktops, date in compass, timestamps in chats...)

* on gubani wheel when the reward choice is displayed (tokens or rewards), the left half displays a red rectangle background - screen capture available.

thanks,
Yovung.

Going on with my small bugs report^^
Beta 891 now - linux x64 through ryztart on linux mint 20.1, en interface

* Still have to reconfigure my desktops at client start
* Impossible to change my daily missions settings. changes don't apply, even after using "preview and save preferences"

Last edited by Yovung (3 weeks ago)

#4 Report | Quote[en] 

Enabling Fmod drivers in windows crashes the client.


Fmod driver is deprecated and will probably be removed in a future release. Same for DSound (https://github.com/ryzom/ryzomcore/issues/65)

If you get issues with Xaudio2 or OpenAL, please open a ticket in https://github.com/ryzom/ryzomcore/issues/

Edited 5 times | Last edited by Tamarea (3 weeks ago)

#5 Report | Quote[en] 

Ulukyn
Fmod driver is deprecated and will probably be removed in a future release. Same for DSound (https://github.com/ryzom/ryzomcore/issues/65)

We cannot support the FMod backend from the open source end, since the version of FMod is no longer available, and thus cannot be licensed anymore. It also misses some features.

DSound should be kept as reference implementation, even if incomplete, since it's what the sound artists originally used. Specifically the 'EAX' reverb effects are not yet fine tuned to sound the same across all drivers. No need to ship DSound to players, though, since it's not useful there.

(The EAX effects were never implemented in FMod at all, by the way, the setting does nothing there. They do work in XAudio2 and OpenAL, but don't match the reference exactly.)

Last edited by Kaetemi (3 weeks ago)

---

Kaetemi

#6 Report | Quote[en] 

A bug reset the whole interface if you talked to a player with a title containing non-ascii characters

It is now fixed

#7 Report | Quote[en] 

Update:
- Classic titles can be applied, but encoding issues happens
- Special titles can't be applied

Encoding issues can happen since it's a big change in core4

#8 Report | Quote[en] 

As noted before, to fully merge the encoding changes:
- Remove `#define RYZOM_LUA_UCSTRING` to completely eliminate ucstring support from lua & ui expressions.
- Then remove all ucstring, toUtf8(), and uc_ prefixes from your lua & xml scripts.
- Add `localize="false"` to the `npc_web_browser` container title.

That should eliminate all encoding issues, since everything will be UTF-8.

But it may be tricky with two different client versions, since you also have scripts server-side...
For most cases you should be able to eliminate the ucstring from the scripts first, after the client is patched for everyone, since regular string will be UTF-8 already. Then disable the macro afterwards.

Edited 4 times | Last edited by Kaetemi (3 weeks ago)

---

Kaetemi

#9 Report | Quote[en] 

You may want to put some breakpoints in the `ucstring` operators, since those do take std::string without converting for some reason... Maybe just make those use `fromUtf8` as well, I don't see the use case for bypassing the encoding there.

---

Kaetemi

#10 Report | Quote[de] 

The Tribe called "Kuilde" from the Nexus region is missing on my fame-list... :-)
uiWebPrevious1uiWebNext
 
Last visit Wed Dec 8 07:20:17 2021 UTC
P_:

powered by ryzom-api