Mutual GNU / Linux


#1 [en] 

Hi, all.

After logging in I get told that the game cannot find:


There is no such file on my system, but there is a "ryzom_00833.idx". I put in a symlink and "voila"! It works.

Probably not the right fix though.

I am running the game using the ryzom_installer_qt binary.

Can anyone tell me how to get the game to correct the version properly rather than the nasty hack I find myself having to use.


#2 [en] 

Save your important files delete the game folder in home/.local/share/ryzom
then reinstall ryzom with installer provided by
This fixed it for me:)

#3 [en] 

In your file manager you will have to go to view > Show hidden to find it

#4 [en] 


I don't use File manager I am a command line boy and I have it configured to always show hidden files :P

Do I have to do this EVERY TIME there is a new release? How crap is that?

And I have so many different config files etc. What do I have to save? I had an old Steam install under the path you give and then installed a proper install under Ryzom_local, but it was still saving files under Ryzom. I just got around to blowing away the old one and renaming the newer one, and I lost all my map landmarks and had to redefine all my keys and settings in the process! I copied so many files across from old to new but must have missed some.

They don't make it easy at all!

Anyway, I really don't want to have to do that, and risk losing some files in the process, every single time there is a new patch :(

#5 [en] 

If you don't mind lossing land marks it doesn't really if you don't save

#6 [en] 

I'm just telling you how I fixed it. took less then 10 minutes. it may vary from player to player. I'm a player just like you so maybe the GM's or CSR will have a better fix.

#7 [en] 

Your landmarks are saved in xml files in your ryzom folder

#8 [en] 

When you get tired of doing everything in the terminal type sudo apt-get install pcmanfm
its the best file manager I have found so far. its very user friendly and can be brought up using the terminal by typing pcmanfm

#9 [en] 

hope this info helps

#10 [en] 

I appreciate your help. At risk of getting sidetracked, I bet your file manager can't copy all files from three different locations with "Tree" in the name but that do not contain "Flower" with only a few seconds effort on the part of the user.

for i in $(\ls -1 a/*Tree* b/*Tree* c/*Tree* | grep -v Flower)
cp $i other_dir

Back on topic. When you say "xml files" it would be nice to have an exact list of files that need preserving in order to save:

*) Key bindings.
*) Landmarks.
*) Notes made in the in game notebook.
*) Anything else useful I may have forgotten.

I really don't understand why landmarks and notes etc. aren't stored server-side, and preferably key bindings as well.

#11 [en] 

All you have to preserve is the "save" subfolder. For patch problems you usually should only have to delete unpack subfolder (and sometimes user subfolder can be corrupted, but more rare).


#12 [en]

#13 [en] 

Well that's not confusing...after deleting the "unpack" folder, the client is now downloading what it "says" is patch 832, the release notes displayed are for 832 anyway, but the file it is downloading to is 833.

I tried stopping the client and copying my original 833 file across, but it just started the download all over again when I restarted the client.

#14 [en] 


Go to the indicated path and delete all files that are located inside the unpack folder, this will re-patch and fix your bug. You can also rename the file ryzom_00833.idx into ryzom_00832.idx.

Best regards.

Last edited by Jadeyn (4 years ago)


Jadeyn | Senior Game Master | Polyglot/Multilingual
Ryzom Support Team

#15 [en] 

Also if you type flower in the file manage it will show everything flower related there easily
Last visit Saturday, 20 April 00:06:07 UTC

powered by ryzom-api