English French German Spanish Russian
Constant Connection Failed - If you have just left the game....blah blah - Technical Support - Ryzom Community ForumHomeGuest

Technical Support


uiWebPrevious1uiWebNext

#1 [en] 

Hi,

I am wondering why i sometimes have a constant connection failed - please wait 30 seconds error when I try to log in on one of our accounts?

It is sporadic but when I get it, it could be a couple of hours before I am able to log in.

It is frustrating and honestly a waste of my time to keep trying to log in. It does not seem to happen to every account we have in my family but it happens a couple of times a week sometimes then we can go 15-20 days without it and boom it is back. I would think it was something on the internet but that would not explain why some accounts log in fine and others do not.

I have a feeling this is something on your end that is causing this. As I can load 2 clients on the same computer and one will log in and the other gets the failed message.

#2 [en] 

I decided to do a test.

when I change my ip (reboot my router) I get the connection failed message on all the accounts, I am assuming it resolves itself over time. I never noticed the correlation since i do not reboot the router often.

Usually about once a month unless we start having issues.

#3 [en] 

well I was able to get in on a couple of the accounts but when I went to swap characters the client locked up, now getting the connection failed again.

3 hours of my life wasted trying to get connected.

Ping and traceroute are clean, no firewall, no settings have been changed on my router other then rebooting it. Computer is the same as the last few days of playing.

ping ex.
64 bytes from shard.ryzom.com (178.33.44.35): icmp_seq=12 ttl=47 time=180 ms

ran it for 10 minutes no burps or lag, ping ran 170-190ms, no packet loss.

oh and all clients patched fine yesterday and all accounts were logged in and playing in the last 3 days.

Take care all.

#4 [en] 

Thought I would come back to play this, hoping this problem would have been corrected but still the exact same issue.

Not on a wireless network, direct connect to a 10meg dsl., I rebooted my dsl modem, swapped dns servers, shut down my firewalls. Even installed the client on a different computer.

All the other games played in this house work flawlessly.

Ryzom, I have to start and login , get the connection failed, close and repeat 20-30 times for each account I try to log in and I might get logged in eventually.

Snipped from the client log, not that it provides much information, Is there a timeout on the login packet sent? I am assuming the servers are in france but not sure that would cause this problem.


2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe network_connection.cpp 456 CNetworkConnection::initCookie : Network initialisation with front end 'newshards.ryzom.com:47851' and cookie 'E6738BBB|0D2A7074|000B4537'
2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe network_connection.cpp 401 CNetworkConnection::init : Half-frequency mode
2018/10/10 08:38:34 WRN 5350 ryzom_client_r.exe big_file.cpp 696 NLMISC::CBigFile::getFile : BF: Couldn't load 'D:/Game Files/Ryzom/gamedev.bnp@shards.cfg'
2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe config_file.h 326 NLMISC::EUnknownVar::EUnknownVar : CF: Exception will be launched: variable "Use" not found in file "D:/Game Files/Ryzom/gamedev.bnp@shards.cfg"
2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe network_connection.cpp 651 CNetworkConnection::connect : There's no shards.cfg, or bad file format, can't copy common files
2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe network_connection.cpp 654 CNetworkConnection::connect : CNET[0000000141AE1010]: Connecting to 'newshards.ryzom.com:47851' with cookie ''E6738BBB|0D2A7074|000B4537''
2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe network_connection.cpp 680 CNetworkConnection::connect : CNET[0000000141AE1010]: Client connected to shard, attempting login
2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe sound_manager.cpp 1350 CSoundManager::update : The current weather setup '' is unknown !
2018/10/10 08:38:34 INF 5350 ryzom_client_r.exe network_connection.cpp 1013 CNetworkConnection::sendSystemLogin : CNET[0000000141AE1010]: sent LOGIN cookie='E6738BBB|0D2A7074|000B4537'
2018/10/10 08:38:34 WRN 5350 ryzom_client_r.exe network_connection.cpp 933 CNetworkConnection::buildStream : DISCONNECTION
2018/10/10 08:38:34 WRN 5350 ryzom_client_r.exe group_html_parser.cpp 333 NLGUI::CGroupHTML::parseHtml : htmlstring parsing failed



Sorry I refuse to pay for a sub on a game I can not even log in and when I finally get in, I can not change characters on.

I will wait another year or so and see if someone figured it out.

#5 [en] 

Hey,

Not sure if that's exactly your problem; but I had some sort of similar problem; my connection timed out in some respects of the game;

keep in mind that I am on Linux;p

So the problem I had was that my ISP couldn't connect properly to the server; so I manually added app.ryzom.com to force it to connect. Because this is a rather lengthy procedure; and one which I did not do alone; had a friend help me fix it; I am unsure what more I can offer here.

I suggest you sent a message via ryzom.chat.com to Riasan or Ulukyn; they will probably be able to help you::)

Star

---

#6 [en] 

Hello Halon,

So, can you give us a clean copy of your client.log please?
And by clean, i mean try to focus on the log lines about: login.cpp http_client.cpp network_connection.cpp

Im curious about it, maybe you are trying to login on a wrong host.

Also, in last ressort could you try to sniff your network data while doing the process of connection?
Wich if i get it right, will end in a connection error; try test:test as login and drop the result in a file here.

.

#7 [en] 

Its unknown if you reinstalled Ryzom or used your older copy. If its older copy, I highly recommend (ie, required) for you to reinstall it because older copy may not patch.

---

Hello!

#8 [en] 

Karu
Its unknown if you reinstalled Ryzom or used your older copy. If its older copy, I highly recommend (ie, required) for you to reinstall it because older copy may not patch.

Thanks all for responding. That surprised me.

I actually tried 3 different installs. Steam, Old and install a new copy from the ryzom installer.

They all act the same, I have about 5% or less chance of getting logged in. I know I was opening 5 clients at a time and did that 6 times in a row to finally get 1 client logged in.

I added exceptions in my firewall, port forwarding in my router, turned off my firewall, set my computer as the dmz in the router. Added ip-address in the host file. I have not tried linux but I may do that next. I am on win10 current but I have manjaro installed as well.

#9 [en] 

Revvy
Hello Halon,

So, can you give us a clean copy of your client.log please?
And by clean, i mean try to focus on the log lines about: login.cpp http_client.cpp network_connection.cpp

Im curious about it, maybe you are trying to login on a wrong host.

Also, in last ressort could you try to sniff your network data while doing the process of connection?
Wich if i get it right, will end in a connection error; try test:test as login and drop the result in a file here.

.



Sure lets see if I can break it all out for you.




goes through a bunch of login_patch.cpp stuff



The only difference between the steam client and the installed one is steam is using the ip address instead of the host name for the same server 176.31.229.93 (newshards.ryzom.com)

Regards and thanks for taking a look.



Added - This is the extract from Steam client.





Edited 2 times | Last edited by Halon (2 months ago)

#10 [en] 

Northstar
Hey,

Not sure if that's exactly your problem; but I had some sort of similar problem; my connection timed out in some respects of the game;

keep in mind that I am on Linux;p

So the problem I had was that my ISP couldn't connect properly to the server; so I manually added app.ryzom.com to force it to connect. Because this is a rather lengthy procedure; and one which I did not do alone; had a friend help me fix it; I am unsure what more I can offer here.

I suggest you sent a message via ryzom.chat.com to Riasan or Ulukyn; they will probably be able to help you::)

Star

Thank you, I will give a try from linux maybe something in my windows is borked. (no surprise there lol)

#11 [en] 

From the steam login attempt log, It seems that firewall, router, or router firewall does not allow the comms to shard.

There has been issues with some routers in the past that do not like Ryzom small UDP packets at all. They either block them or drop them after timeout (ie 10min disconnect)

---

Hello!

#12 [en] 

Karu
From the steam login attempt log, It seems that firewall, router, or router firewall does not allow the comms to shard.

There has been issues with some routers in the past that do not like Ryzom small UDP packets at all. They either block them or drop them after timeout (ie 10min disconnect)

@Halon What about the network data? (use wireshark if you dont know what to use on win)

.

#13 [en] 

Karu
From the steam login attempt log, It seems that firewall, router, or router firewall does not allow the comms to shard.

There has been issues with some routers in the past that do not like Ryzom small UDP packets at all. They either block them or drop them after timeout (ie 10min disconnect)

Well I had some time this morning so I swapped over to linux, it works fine there. I guess it is something in my windows setting, I was able login to all my accounts on the first try.

Thanks all, I will continue to look into the issue with my windows configurations on both systems to see if I can narrow the issue down.

Oh this was on both steam and standalone install of Ryzom on Linux. (manjaro dist)

Last edited by Halon (2 months ago)

uiWebPrevious1uiWebNext
 
Last visit Tue Dec 11 11:55:11 2018 UTC
P_:

powered by ryzom-api