#31 Report | Quote[en] 

Just a thought... Is it possible for you to install Linux on your secondary drive? And install ryzom on that?

I have heard quite a few people are having problems with win10.

No offense intended.


The Clan

#32 Report | Quote[en] 

Hm, cant you run linux client under that linux enviroment in win10? or is it slow? I never tried due i have no Windows...

#33 Report | Quote[en] 

In order:


Seems like the installer doesn't run, although I don't get the "no you suck, you have no memory on your hard drive" error now.

This is latest version of Win10 64bit, non SSD HD. What else do you need to know? I was trying to get most of the info on the screen.

"Retry" does nothing, "Ignore" came up with this result.


The reason is very simple :)

You just need to close Ryzom Installer before to install it again :p

It's normal it can't overwrite an executable that is already launched :)

I don't know if you noticed but it was still in memory in your Task Manager.

Last edited by Xiombarg (5 years ago)


Kervala - Ryzom volunteer developer - Working on different clients

#34 Report | Quote[en] 

ok, step by step.

0. Gotta start somewhere.

1. Run "ryzom_installer_qt_r.exe.

2. Get the same result as before. Ignore, Retry, Abort. Retry gets you nowhere. Abort gets you to the same place as Ignore, and the "Ryzom Installer Setup" window re-appears.

3. Go to task manager and close it down.

4. The installer program window goes away. The installer is supposed to install to D:/Ryzom, but it does not.

5. Re-open "ryzom_installer_qt_r.exe in d:/Ryzom as per 1.

6. Get the same result as before. Ignore, Retry, none of it works.

7. Continue this cycle.

I think you just told me the dev equivalent of "make sure your computer is plugged in." It's only a joke on your end, sadly. :(

How is this simple to solve?



#35 Report | Quote[en] 

It fails because you launch ryzom_installer in D:/ryzom, so it tries to install himself, and can't copy over the ryzom_installer.exe in D:/ryzom cause it's used (by himself)

Remove all files in D:/ryzom, put ryzom_installer anywhere NOT in D:/ryzom, launch it and chose D:/ryzom as installation path.

Last edited by Lopyrech (5 years ago)


#36 Report | Quote[en] 

That should hav fixed the immediate problem but not the ultimate one, and I think it did, although I didn't do what you said.

As it turns out, the ultimate problem, that being why the game itself wouldn't install, was caused by something else.

I was able to fix it because I found out what it was doing, by chance.

When the installer installed to the d:/ryzom folder, it wasn't checking there to see that there was enough memory in the d:/ryzom folder.

Instead, it was checking a folder I had previously deleted, namely c:/ryzom 2016. So it was coming up with the dialogue box that said you don't have enough memory to install the program (because the folder that it was trying to install to didn't exist).

I don't know why it was doing this, but it was.

When I remade the c:/ryzom 2016 folder with nothing in it, it then installed to that folder instead of the one it was directed to, being d:/ryzom, and I can now run the game.

This makes no sense, but it works.

Thanks for your help everyone :)

EDIT: Kervala, this is with the 64bit Win10 beta from your website.

Edited 5 times | Last edited by Sassafras (5 years ago)



#37 Report | Quote[en] 

I think there is something in the installation that says something like install to c:/ryzom or in linux /home/user/.local/share/Ryzom.

This is similar to the problems I was having in the sense that the path is looking one place for data /home/user/.local/share/Ryzom and not checking the old location /home/user/.ryzom for the information where I had the game installed.

I believe this has to do with the migration to a new home directory for the game that you don't need administrator privileges to run the game.

Back in the day we had to write each directory and subdirectory we wanted it to check in the path command.

No offense intended Gidget. Just hope this helps.

#38 Report | Quote[en] 

This makes no sense, but it works.
Thanks for good error report. Its actually quite simple, Ryzom installer is reading old location from files left over on AppData directory and does not handle the situation correctly when that location does not exist anymore.



#39 Report | Quote[en] 

I was reading the topic as my sisters experience lag and trees mooving trouble in the game, and i wanted just to react on nume's trouble and installation process under linux.

I'm on a standard debian jessie 64, and i: just download and extract the latest corresponding kervala's beta client, on a dedicated "ryzom" folder just created in my user home (~/ryzom), and then, after allowing the to be executed, i just launch it.

it then "patch, patch, and patch"^^ and i'm able to play.

To get my interface back (for new install on another computer), i just copy my backuped save directory files in the ~/ryzom/save folder.

thats just it and whenever a crash mess every thing up (sound activated crash does on my computer), i just click on the ryzom_client_patcher

if it helps other linux user

#40 Report | Quote[en] 

Hum I don't understand why your installer is called ryzom_installer_qt_r.exe :(

It should be :

Did you rename ryzom_installer_windows.exe to ryzom_installer_qt_r.exe ?

They are not the same :(

ryzom_installer_windows.exe is a NSIS package to install ryzom_installer_qt_r.exe.

Edit : Steps to install Ryzom are :

1. download and save it somewhere (but not in the location you'll install Ryzom please)
2. launch ryzom_installer_windows.exe
3. choose the location where you want to install Ryzom Installer
4. wait until it downloaded and uncompressed everything
5. click on Play

Last edited by Xiombarg (5 years ago)


Kervala - Ryzom volunteer developer - Working on different clients

#41 Report | Quote[en] 

I already know that, Xiombarg :)

You can't rename the initial installer and make it a different program.

The first one is what you download from the ryzom website.

When it is installed, it gives you the second one, which you then run to install the program.

That was the trouble. The initial installer stopped and would not install the second program. The reason for that was that it was misdirected to a non-existent folder.

When I recreated the non-existent misdirected folder, the program worked.



#42 Report | Quote[en] 


now I'm back to the original problem:

disconnect disconnect disconnect

Far more with v.3 than with v.2 on a stable high speed connection and 2 machines on a network that ran without disconnects pre-v.3.

Oh well.



#43 Report | Quote[en] 

Thanks :)

Please could you send me your client.log to so I'll be able to check if there is any error or warning related to that ?


Kervala - Ryzom volunteer developer - Working on different clients

Last visit Sun Aug 1 04:34:02 2021 UTC

powered by ryzom-api