English French German Spanish Russian
Windows 10 64 bit :: Directx9 :: Client 2.9 and 3.0 (latest release) - Technical Support - Ryzom Community ForumHomeGuest

Technical Support


is there any solution?
yes 0
no 0
Other 0
Abstain 4
uiWebPrevious1uiWebNext

#1 Multilingual 

Hello Support-Team,
after installing windows 10 and directx9 I downloaded ryzom 644 installed it and after a bigger patch installing it runs pretty well.

Then I downloaded client 2.9 latest version extacted is as well as the data 2.9 copied both into the ryzom home directiory and got after starting an error with message couldnt start due to error Cxfrdess (or something like that) then I deleted the complete ryzom directory copied the oringinal back and it runs.

After extracting client 3.0.0 the same error happens and 2.7 runs after recopying it back again very well.

I am not able to find any reason for the error. But would be fine if there a solution would be find.

regards
Rubee

#2 [en] 

What you problem might be permission issues if Ryzom is installed and started in c:\Program Files directory.

r644 did require admin privileges to run, not sure if v2.9, v3.0 clients have that enabled or not.

Solution for that is to copy Ryzom somewhere that is not considered system directory by windows, or start windows in such directory (copy client.cfg, client_default.cfg files, and save, user directories to there also)

---

Hello!

#3 Multilingual 

Hello Karu, as you adviced I installed ryzom 644 in my own home directory in windows, started 2.7 and it runs. After that I downloaded client 2.9_win64 as well as the same ending data for 2.9 and both for 3.0 and I got for both the same error massage again:

The application couldnt be startet (0x000007b) click OK to close the application :(

regards
Rubee

#4 [en] 

Maybe installing vc++2010 redist package helps
https://www.microsoft.com/en-us/download/details.aspx?id=14632

---

Hello!

#5 Multilingual 

After installing the vc++2010 redist package and rebooting I received the same error-message. So unfortunately nothing change except new/other non required software.

And it seems not clear for me that such error happens, cause I have a nearly clean Windows 10 installation with the standard apps and only additional the Office 365 home. So there cant be something strange I think. And the 2.7 client runs without any problems.

Do I need to do something more then copying the 2.9 or 3.0 client into the Ryzom directory and the 2.9 or 3.0 data files into the ryzom/data? Anything to start? Cause the Background_update.exe stopps after the above mentioned copying with the same error then the client_ryzom_rd.exe

regards
Rubee

#6 [en] 

I installed windows 10 (1511) 64bit, video drivers from windows update (ati).

I did not install Ryzom r644, but copied other install (basically data folder only)

Downloaded beta client (64bit) v3.0.0.7529 (with same version data).

Ryzom is currently patching. I did not install directx9 or vc++2010 redist.

I did notice that beta client archive has needed d3dx9_43.dll, msvcp100.dll, msvcr100.dll included.

You may try to remove (to separate directory) all .dll and .exe files from ryzom folder (most are probably obsolete anyway) , unpack beta client archive and try again.

---

Hello!

#7 [en] 

I did as told, but I am still wondering that in the client (64bit) v3.0.0.7529 NO ryzom_client.exe exist !!! How did you start the Programm when you deleted all *.exe and *.dll before?

#8 [en] 

Rubee
I did as told, but I am still wondering that in the client (64bit) v3.0.0.7529 NO ryzom_client.exe exist !!! How did you start the Programm when you deleted all *.exe and *.dll before?

name was changed to ryzom_client_r.exe

---

Hello!

#9 Multilingual 

Yes, that I found out already, but in the file ryzom_client_static_win64_3.0.0.7529 is NO ryzom_client_r.exe only a crashreport.exe.

and when I use the ryzom_client_r.exe from latest 2.9 7z it will start and make a huge update, but as soon as it restart after patch it didnt run again cause it always create an new "wrong" client_default.cfg.

So its not correct.... I am sad about it.

#10 [en] 

Rubee
Yes, that I found out already, but in the file ryzom_client_static_win64_3.0.0.7529 is NO ryzom_client_r.exe only a crashreport.exe.

that archive has 16 files. one of them is ryzom_client_r.exe

---

Hello!

#11 [en] 

You where right, there was a mistake in 7z program. but nevertheless this exe also overwrite the client_config.cfg after loading the patches and it stopped always with an Open_GL file not found error. so it wont start in automodus for DirectX only as OpenGL and that didn't work cause I havent installed OpenGL.
So I will give it up to try to run an newer client then 2.7 with Windows 10 for now. Its pretty sad, but I dont know what I am doing wrong.

regards
Rubee

#12 [en] 

Rubee
..., but nevertheless this exe also overwrite the client_config.cfg after loading the patches and it stopped always with an Open_GL file not found error. so it wont start in automodus for DirectX only as OpenGL and that didn't work cause I havent installed OpenGL.
client.cfg is the file you change and not client_default.cfg. consider client_default.cfg as read-only.

you can use ryzom configuration exe to change display settings to direct x

---

Hello!
uiWebPrevious1uiWebNext
 
Last visit Fri Feb 22 23:35:53 2019 UTC
P_:

powered by ryzom-api