English French German Spanish Russian
[Resolved] Cannot take screenshots in Ryzom any more. - Mutual GNU / Linux - Ryzom Community ForumHomeGuest

Mutual GNU / Linux


uiWebPrevious1uiWebNext

#1 [en] 

First, I have had a stroke and am slightly brain-damaged, so bear with me.

Problem:
I have "joined" the Ryzom MORPG about a year ago, and up until a few months I had used the screenshot keys and have taken screenshots. Now, a few months ago, I couldn't take any more screenshots.

I am running under Debian Linux (Stable version with a few testing packages installed). My Ryzom keyboard IS set up, as default, to use ALT-F10 for png, CTRL-F10 for some other image format, and, I think, SHIFT-F10 for yet another image format. (Well, I prefer PNGs, but I have tried all three formats). But, no soap, it just sits there not capturing my screenshot.

Now, I had tried once to redefine the keystroke to another keystroke, but when I attempted to enter the key to redefine it, Ryzom screamed and died and had crashed.

Additional information.
I have an 8-core processor, 12 GB of memory, an Nvidia graphics card (GTX 650).
I have a 64-bit OS, but I have installed all the appropriate 32-bit packages to run Ryzom.

I think that's about it, can anyone offer any suggestions to my lack of screenshot capabilities?
While I do have workaround using ffmpeg to capture my entire game play, that option is a little weird.

That you for your time, and have a good day.

Last edited by Tamarea (5 years ago)

---

Water the tree, not the fruit.

#2 [en] 

When you say you are not taking a screenshot, do you mean that you can't find the screenshot or that there is no message in System Info saying "screenshot screenshot001.png saved"?

I can think of several reasons. (I assume that you double checked your key assignments in game after the attempt to change keys.)

1) You have taken more than 1000 screenshots and there is a failure bug when Ryzom tries to create screenshot1001.png . If this is the case, moving the current screenies out of the ryzom directory will allow Ryzom to make more screenshots.
2) Some outside keyboard program has changed the code produced by your keyboard when you hit Alt+F10.
3) Somehow the storage directory for the screenies got changed.

Hope this sparks a thought that leads to the true reason.

-- Bittty

---


Remembering Tyneetryk
Phaedreas Tears - 15 years old and first(*) of true neutral guilds in Atys.
(*) This statement is contested, but we are certainly the longest lasting.
<clowns | me & you | jokers>

#3 [en] 

Nope, It is not in the appropriate directory. Ubtil a few months ago it was in, I think, /opt/ryzom/scrrenshots. There are no screenshots anymore. Also, I have checked the permissions on the directories. I am not going to mess around with the Ryzom configuration files, however.

#4 [en] 

i'll direct a friend that is well versed in linux to this issue as soon as he returns from vacation, perhaps he can find the issue your suffering and how to fix it.

---

Remickla (atys)
Other games - they give you a cookie whether you succeed or not, in fact you don't even have to participate. Ryzom takes your cookie, eats it in front of you, and slaps you 2 or 3 times for bringing a cookie in the first place.
What Cookies is about ---- Contact Cookies ---- Cookies at Events ---- For Cookies Diggers and Crafters
Useful Links:
cookies approved referance data, guides, and more. --- ryztools web version --- talkIRC forum post table of contents

#5 [en] 

1)What client version are you using ? Official one ?
2)When you take a screenshot, is there any message in sys infos ? (like screenshot001.png has been saved)
3)Try to change your key binding ; it can be possible that your WM already have alt+F10 used as shortcut. For example, in gnome3, alt+f10 is windows resize :)
4)Is there anything in your client.log about this ?
5)If you can, come on IRC, it's really faster to help you (#ryzomsupport on freenode, quick link : webchat.freenode.net/?channels=ryzomsupport )

---

#6 [en] 

Back when I was able to take screenshots, I empied them periodically to another directory.

Also, there is no longer a message when I enter the keystroke LAT-F10.

I use the official version of Ryzom (didn't know if ther was an "unofficial" version.

I will have to check and see if my Linux keybindings have changed.

#7 [en] 

Macsmith (atys)
Back when I was able to take screenshots, I empied them periodically to another directory.

Also, there is no longer a message when I enter the keystroke LAT-F10.

I use the official version of Ryzom (didn't know if ther was an "unofficial" version.

I will have to check and see if my Linux keybindings have changed.

so if there is no message the keystroke is a)not alt-f10 (changed) b) "captured" by your windows manager. Try to set it to something not used, like shift+alt+F10 (try a couple of different keystroke to be sure).

---

#8 [en] 

First, I have several characters that I have/use. I am also known as Kovabon, MacSmith, Vagia, Xanix, and Mate.

Anyway...

As per your advice on my keybindings in Linux, I use KDE, Fluxbox, and XFCE. And all of those window managers have a binding in the window manager. I have ERADICATED those keybindings in the window managers, and I can now use screenshots, once again.

YEAH!!

Thank you, Bittymacod, for you excellent advice.
Have a good day!
uiWebPrevious1uiWebNext
 
Last visit Mon Jul 22 09:46:52 2019 UTC
P_:

powered by ryzom-api