English French German Spanish Russian
Black screen (but not dead window) after creating character - TECHNICAL SUPPORT / WEB APPs BUGS - Ryzom Community ForumHomeGuest



#1 Quote[en] 

Hi everyone :) I've just met Ryzom these days and it attracted me with it's graphics in the screenshots, so I decided to give it a try. Downloaded it, extracted (I'm on Debian), ran the update, then start.

It worked well (with tons of lag, because my computer is relatively old). I log in my account, went to the character creation screen, created my character, and chose the world (there's only one option - Atys (World Community)), then key bindings (I chose WASD), and character name.

But after character name the window dimmed black. Then no more response from it...(the point is my cursor is still working fine in the Ryzom window, and Ryzom is still working with high CPU usage).

So what actually happened? Can anyone tell me and help me to solve this?

#2 Report | Quote[en] 

Debian... the (in)famous "always outdated" Linux distribution :-D

There are a few things I'd like you to verify/try

1. There should be an updater script in the ryzom folder (don't remember the name) have you tried running it?
2. On the login screen you should see the version of your client iirc - which one are you using?
3. What kind of gfx card does your system have?
In general the game has most problems with intel cards (lots of things not supported by the hardware)
Linux in seems to have trouble with ati/amd (or the other way around as it's the crappy drivers' fault)
4. What gfx driver are you using? If it's the free/open amd/ati/nvidia one you should change to the proprietary version.


#3 Quote[en] 

After having this problem the first thing I did is running the ryzom_update.sh included in the archive. So it ran for quite a while and updated everything. Then I relaunch the game (it gained more FPS...so updating helps a little), but the problem is not solved.

Well that should be the latest Linux version available. ryzom_update.sh updated ryzom_client as well.

Graphics card...(ouch) it's an old Intel that only have OpenGL 1.4 (and the best game I've ran on it was SuperTuxKart, and a couple of MMORPG both 2D and 3D when I'm on Windows, including MapleStory).

Based on the Wiki I saw that a minimum of GForce2 Series from NViDia is required and from some benchmarks I found that my card was just a little lower spec than the worst GForce2 I can see from http://www.videocardbenchmark.net/low_end_gpus.html

This is my graphics card: http://www.videocardbenchmark.net/gpu.php?gpu=Mobile+Intel+945GM+ Express+Chipset+Controller+0&id=1082

This is the GForce2 I see on top of my card: http://www.videocardbenchmark.net/gpu.php?gpu=GeForce2+MX%2FMX+40 0&id=1479

For me it doesn't have much difference :P and someone at #ryzom IRC told me that my card is okay for the game.

Since it's Intel, so...the out-of-the-box driver from Debian == and there's no update available.

#4 Report | Quote[en] 

since you've already been to #ryzom @ freenode I suggest that you ask the guys there as they've got much more knowledge about the subject than I do.

But maybe someone else here has a good suggestion except "buy the cheapest nvidia card available" ;-)


#5 Report | Quote[en] 

Filing a ticket never hurts, you can do it even from the web interface.


Last visit Wed Oct 16 12:17:45 2019 UTC

powered by ryzom-api