English French German Spanish Russian
enddless frequent Please Wait... - TECHNICAL SUPPORT / WEB APPs BUGS - Ryzom Community ForumHomeGuest

TECHNICAL SUPPORT / WEB APPs BUGS


uiWebPrevious1uiWebNext

#1 Report | Quote[en] 

I get anywhere from 10 minutes to hours of gameplay, but I get Please Waits that never end... sometimes they are very requent. I have to play with the task manager open to close the program after it hangs.

During the "Please Waits" I am unable to chat or move, but I am able to update my info section.

There doesn't seem to be anything I can do about it... I remember I had these problems with the game on release (on a different computer on a different internet connect). It's why I decided not to play. It makes me too unreliable to fight with other people.

This is my trace route report, its out of 7119 traces.


Target Name: su1.ryzom.com
IP: 178.33.61.58
Date/Time: 10/27/2012 1:12:26 AM to 10/27/2012 3:14:32 AM

Hop Sent Err PL% Min Max Avg Host Name / [IP]
1 7118 7 0.1 0 14 0 [192.168.0.1]
2 7118 7118 100.0 0 0 0 [-]
3 7118 38 0.5 6 38 8 [67.59.238.57]
4 7118 13 0.2 9 40 11 rtr3-ge1-4.mhe.hcvlny.cv.net [167.206.37.1]
5 7118 12 0.2 9 39 11 static173-corevault-chy.intelleqcom.net [64.19.99.173]
6 1436 2 0.1 9 53 11 [64.15.1.106]
7 7118 1562 21.9 9 208 13 eqx.ny.ovh.net [198.32.118.106]
8 7118 1020 14.3 9 151 14 nwk-2-6k.nj.us [178.32.135.228]
9 7116 4989 70.1 79 156 84 ldn-5-6k.ovh.net [198.27.73.10]
10 7118 2528 35.5 82 139 85 rbx-g2-a9.fr.eu [91.121.128.167]
11 1943 1877 96.6 83 97 85 rbx-s3-6k.fr.eu [213.251.128.2]
12 7118 7118 100.0 0 0 0 [-]
13 7118 1441 20.2 81 125 84 shard.ryzom.com [178.33.61.58]

I played the game while I was generating this, and I didn't notice any extensive packetloss while the traceroute was running...

There were also moments when I experienced packet loss and just jerked around a bit... and "please wait" flickered on the screen.

I've forwarded all of the ports that were recommended in the email I received.

I'm using a netgear fwg114p router.

#2 Report | Quote[en] 

3 days and no response:( Yeah i get the same ALOT. my ping is usually in the 350+ range. packet loss varies. have to quit and restart the game fairly often some days. not sure if it's a game issue totally. i have at&t internet and they really suck.

#3 Report | Quote[en] 

With Ryzom, one can have a ping of up to 800 or so without experiencing any lag, packet loss, or Please Waits. So ping isn't actually part of your problem.

Unfortunately I have no other knowledge to offer.

#4 Report | Quote[en] 

PW's, unless they are being reported by everyone at the same time, are almost never a function of the server or the client, but of the connection.  This is my observation, not a theoretical statement.

Ping from the US is almost always 350-500 when you have a good connection.  The cause of PW's is not variation in ping, but the download and upload speeds, especially download. There are ports on your router that should be opened for the ryzom server, too. Check the forums.

Hope this helps --  Bittty

---


Remembering Tyneetryk
Phaedreas Tears - 15 years old and first(*) of true neutral guilds in Atys.
(*) This statement is contested, but we are certainly the longest lasting.
<clowns | me & you | jokers>

#5 Report | Quote[en] 

Looks very much like a routing or connectivity issue on the internet. 20% packet loss is very bad. Those routing issues have been resolved in the past. However the ryzom devs will need to file a complaint with their hosting company.

They might need more traceroutes during different times of the day. You should also contact a GM to point dev's attention to this thread.

---

Casy * Foreign Secretary * Alliance of Honor
Intensive Care Bear

#6 Report | Quote[en] 

Here is my tracert and ping info and I get PWs as well....and sometimes very frequent.
Tracing route to shard.ryzom.com [178.33.61.58]
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms 192.168.2.1
2 4 ms 3 ms 2 ms 10.255.252.1
3 3 ms 3 ms 3 ms te-0-1-0-0-82.cr01.
82.194]
4 4 ms 3 ms 3 ms xe-0-0-0-new.gw01.h
.99]
5 * * * Request timed out.
6 92 ms 91 ms 91 ms rbx-g2-a9.fr.eu [91
7 91 ms 91 ms 91 ms rbx-s3-6k.fr.eu [21
8 93 ms 91 ms 91 ms shard.ryzom.com [17

Trace complete.

C:\Users\Stephen>ping 178.33.61.58

Pinging 178.33.61.58 with 32 bytes of data:
Reply from 178.33.61.58: bytes=32 time=91ms TTL=47
Reply from 178.33.61.58: bytes=32 time=91ms TTL=47
Reply from 178.33.61.58: bytes=32 time=91ms TTL=47
Reply from 178.33.61.58: bytes=32 time=93ms TTL=47

Ping statistics for 178.33.61.58:
Packets: Sent = 4, Received = 4, Lost = 0 (0% l
Approximate round trip times in milli-seconds:
Minimum

---

#7 Report | Quote[en] 

Very often, apart of any server problem ryzom can have, the cause of the please wait is caused by packet loss.

Packet loss cause the client and server lose syncronization and try to resync (this is what happens during the please wait window opened) resending packets till both resync. If a resync cannot be issued after a certain time, the connection between server and client is lost.

This behaviour is mostly needed because network engine of NeL uses UDP packets for communications.

When you can get packet loss? One source can be an heavy loaded server, in this case you cannot do anything, but in this case, everyone on the server would have problems, not just you.

But there is also another reason for packet loss: network fragmentation, that means network packets are fragmented due to a wrong network configuration, client OS side (almost all windows system are never well configured by default), or because of a misconfigured router in the path.

If you are on windows system, try to use tcpoptimizer (google it) to check your connection and, most important, if you have fragmentation, then fix it. That progrram will check your connection and see if you have any fragmentation during transfers, then you can find the correct parameters to solve it.

Another parameter very important is RWIN. I'm not going to explain what it is, but it is another important source of misconfigured network. Having a wrong RWIN (almost always in windows systems) can cause a lot of performance problems. the program will help to find the correct RWIN, based on your average network ping.

Having a correct TCP/IP configuration, expecially in windows system, can help a lot in getting a good internet connection in general, not just for ryzom.

NB: generally ping will not show any packet loss, in normal situations, but is not a valid result, because ping uses by default, a packet size of 32. To see a real ping for packet loss, you should change the packet size up to MTU and see if there are packet loss. This is what tcpoptimizer do.
If you get fragmentation (and then packet loss) before you reach max size, normally 1500 or 1492 for PPPoE, you are easily into troubles.

Finally, for my actual ryzom experience, i have seen a server side problem, but in general it's not very dangerous in terms of playability.
I generally get PW's only when it's a server side problems (such as last sunday), and I don't get any (visible, because sometimes there is a slowdown but not so heavy to require the pw window opened).

Also, server side problems can also be caused by hungry yubos at datacenter, with devs trying to quiet them and wasting the performances with useless coding :D

It's obvious that the server is much more loaded than before merge, as we are getting all 3 old server people into a single one, but hopefully, WG can improve it once they can afford an upgrade.

Hope this can help a bit to solve your issues.

---

Gilgameesh
Silvae Custodes
uiWebPrevious1uiWebNext
 
Last visit Sun Nov 17 17:14:40 2019 UTC
P_:

powered by ryzom-api