Web Apps



Casy (atys)
You could try to add an app at and report back... i don't have a local webserver running.
Did. It wasn't added in a regular browser after 3 tries. I did not keep trying.

Last edited by Hekla (1 decade ago)


Did some testing, you can work locally. Hosted the following script at




and added it ingame as "App".

Here is the (blackened) result:

None of this data should be taken as validation without confirmation, if the api script works this might be a possibility. I would suggest adding a simple password form to get access, keep it simple as they say :)


Actually, I did not try with, but with a local domain (haven't used an IP address for local development in years). I thought it may have been with using .tld extensions for my local domains, but no luck. Domain.com doesn't work either. Tried with everything properly set and a local favicon.png image, tried with trailing slash and expliciting script name as test.php, but could not get it to register in Firefox or Chrome or in-game.

I'm leaving the auto-generated key parameter as is.

Curiously, it doesn't work either when I try to register a php script off a web address. That's a hard one to pinpoint without any error message.


Does not work at all for me.



It seems we found the reason, the server checks for a unique app name. This makes sense for official Apps, but is a bug for personal Apps. Thanks to karu for discovering this issue ;-)

It is not possible to add the same Name twice, but it is possible to add it with a random Name and later change it. To fix this, simply remove the check for duplicate names on custom Apps.


It seems to work now.

Anyway. Checking for duplicates might not be a bad idea but it should check for duplicates in one account instead of all accounts. I have been trying "test", "arcdb", "asdf", ... nothing worked until I tried some more/long random names.

This is also a bad way of coding. Whenever you negate or decline an operation, you should always, always, always, always, always, always output an error/excuse/explanation message.



Okay, so that's why "Test" failed consistently... I'm hoping woodyallenrox is still available. Don't anyone else dare reserve that name before I do.


Thank you, Arcueid and Karu, for tracking down this issue.

Last edited by Hekla (1 decade ago)


It should be fixed now, you can use any (duplicate) name again. Haven't tested it though.
Last visit Thursday, 22 February 23:48:20 UTC

powered by ryzom-api