Technical Support


#1 [en] 

Writing this from a machine with Windows 10 x64 freshly installed.

I downloaded the latest installer from the Ryzom website. It creates a folder with the following 3 files:
  • ryzom_installer_qt_r.exe
  • msvcr100.dll
  • msvcp100.dll
The issue is that, if I double-click the executable, I get the following message: "The code execution cannot proceed because MSVCR120.dll was not found.", after which the installer stops.

Some forums suggest installing the redist package for Visual Studio 2013. I did that, and I do have a copy of the file in c:\windows\system32. The Ryzom installer doesn't detect its presence there.

If I copy msvcp120.dll manually to the folder with the Ryzom installer, I just get a message "The application was unable to start correctly (0xc000007b)".

Any thought welcome, I have exhausted my own ideas.

Última edición por Laoviel (2 years hace)


My home is always sweet Yrkanis..

#2 [en] 

Well ... new reply since I'm too floored to edit the previous post.

As mentioned previously, I had googled and downloaded "Visual C++ Redistributable Packages for Visual Studio 2013". Since my OS is on 64 bits, and I expect most programs these days to work on 64 bits, I also downloaded the redist package for .. 64-bit.

Turns out I needed to download & run vcredist_x86.exe instead. And now the game is happily installing.

Maybe the installer needs a sort of pre-requisite list on the website? Just a thought ... ☺


My home is always sweet Yrkanis..

#3 [en] 

I noticed the same issue with a fresh 32 bit windows 7 install. The first executable from the homepage ( worked, but a click on "Ryzom Installer" shows the missing msvcp120.dll error.

After installing the C++ Redistributable everything worked again. Maybe include the redist and install it like steam does for every game?



#4 [en] 

same with windows 8.1


Mon profil sur le wiki Francais

Craftjenn, Ranger
Last visit dom 07 mar 2021 14:37:04 UTC UTC

powered by ryzom-api