Entraide GNU/Linux


#1 [en] 

Hey all.

Has anyone here managed to get Ryzom working under Linux Mint 13.10 with integrated Intel HD graphics ?

I have an I5 running on a Gigabyte GA-H87M-HD3 board with on board Intel HD graphics. Unfortunately there does not seem to be an Intel driver available for Mint so I'm using the Ubuntu driver currently.

When I play the game the buildings/characters/npc's have no texture maps and are displayed white.

If anyone has a fix for this or has managed to make this sort of set up work I'd love to know how.


#2 [en] 

You might want to search the previous support forum posts in addition to asking here. Complaints about onboard intel graphics are common, especially for Linux.


Remembering Tyneetryk
Phaedreas Tears - 15 years old and first(*) of true neutral guilds in Atys.
(*) This statement is contested, but we are certainly the longest lasting.
<clowns | me & you | jokers>

#3 [en] 

Hey Bittymacod.

Thanks for the reply.
I did a couple of searches before I posted, but have since done a couple more. I found one with a similar problem and tried the fix from there, (Adding a ppa for bleeding edge drivers), but this does not seemed to have helped.

I was hoping someone would have a similar set up (Mint with Intel HD graphics) and would maybe have a fix.

Currently my screen looks like this :-

Any advice or pointers much appreciated.

I do have a spare Nvidia 8800GTX card so will try and get that working with my board, but have failed before, hence the dodgy on board graphics.

Thanks again.


#4 [en] 

Do you have access to an other system? (with nvidia/ati gfx)
Maybe at a friend of yours or something the like?
You could verify your build there (if textures are missing)

What's the problem with getting your nvidia card to work? (where does it stop working)


#5 [en] 

Hey Jarnys.

Thanks for the reply. I don't know anyone with a Linux box I'm afraid. Everyone I know uses Windows, but I'm working on them and will eventually turn them to the penguin :)

My card fails from boot. I get no graphics, not even a post screen. I have not as yet tried to install the card again, but will do that this evening or tomorrow at some point.

#6 [en] 

try installing ia32. the ia32-libs fixed video issues on both nvidia desktop and intel laptop.

If you are running a 64bit install you probably have multiarch which doesn't seem to play nice with older 32 bit stuff

Hope that helps :)

- Noot




I don't wanna die without scars

#7 [en] 

I am personaly running debian jessie with intel graphics, and I am very happy with the performance. I have in the past had issues with newer hardware and older kernels. my system is many moons old, so the drivers are pretty mature. I really dislike the nvidia drivers and have not recently experienced the ati. my lspci -vv output for my card is,

VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Kernel driver in use: i915

a quick search for your board showed up

"The GigaByte GA-H87M-HD3 (rev. 1.x) does not support onboard graphics. Any system build that uses this motherboard therefore requires a separate graphics card, or a processor that has a GPU on the same die, such as AMD APU processors. There are 1 PCIe x16 slots on this motherboard. This means it is perfectly capable of accommodating the latest graphics cards, although it is important to try and use a graphics card with the same graphics card interface of PCIe v3.0, as anything below will not reach the motherboard's potential, and anything above will have its performance slashed to the bandwidth maximum of the GigaByte GA-H87M-HD3 (rev. 1.x)'s PCIe v3.0. The GigaByte GA-H87M-HD3 (rev. 1.x) does not support multiple graphics cards via Nvidia SLI or AMD Crossfire. "

good luck.

#8 [en] 

@Huigro: The mainboard has onboard gfx functionality (see http://www.gigabyte.com/products/product-page.aspx?pid=4517)

@Mooka: If I'm seeing it right it's an UEFI board which often gives trouble in combination with Linux... try taking a look at this thread in the ubuntu forums http://ubuntuforums.org/archive/index.php/t-2190908.html

Dernière édition par Jarnys (il y a 6 ans).


#9 [en] 

I did not even think of bios trouble especially for graphics, as I have no experience with uefi...
Last visit lun. 28 sept. 2020 08:17:54 UTC UTC

powered by ryzom-api