Mutual Mac


#1 [en] 

The Mac 1.12.1 version of the game is experiencing problems where you can crash or be unable to log in after logging out.

The cause is the micro-vegetation in some areas of the game. To stop the crash and be able to log in, you can turn off the microvegetation.

To do this, you will need to modify your client.cfg file. It is located in ~/Library/Application Support/Ryzom.

Follow these steps:

1. make sure you are logged out of ryzom

2. open client.cfg in a text editor.

3. add the following line to your client.cfg:
MicroVeget = 0;
(There must be a semicolon on the end, if there already is a line starting with MicroVeget,  please change that line.) 

4. save the file

You should now be able to log back into Ryzom.


Other settings you can try to modify to see if they work:
SoundOn = 0;
DisableVtxProgram = 1;
DisableVtxAGP = 1;
DisableTextureShdr = 1;

Edited 8 times | Last edited by Sywindt(Yubo) (10 years ago)


Sywindt | Game Master | EN, NL, de, fr

#2 [en] 

Had someone experiencing this problem last night, but none of us online were able to really help because no one else (speaking up) was a Mac user. We came to the conclusion that if you log in another character, or create a new one, and disable Micro-Vegetation on that character, then it will affect the other characters as well.

- Create a new character, or login on a different character than the one experiencing the problem

- Open Game Configuration (U), expand the Graphics menu, and select Landscape.

- Remove the checkmark in Micro-Vegetation.

- Log out, and login with the character experiencing the problem. It should be fixed now.

This may be helpful to anyone who isn't able to find the location of the client config files but who is still able to login with at least one character.

#3 [en] 

I don't have this problem, on an iMac, set to high.

#4 [en] 

For Mac users that crash near water, the
DisableTextureShdr = 1;
 option should fix the problem.


Sywindt | Game Master | EN, NL, de, fr

#5 [en] 

Thanks. I have not seen this one but will keep in mind.

#6 [en] 

I have been playing for about a month on my MAC. I have experienced intermittent crashes but have normally been able to log in until last night (30/9). I tried several times to log in and got as far as ,the ring that completes then you enter the game, only i didn't. Each time the game crashed and presented me with the option to send a fault report to apple, so i created a new character to see if it would load and it did !
I played for a while then tried to play with my original character but it still crashed so i deleted the new character and tried again and again but i still can't play. Its now the next day and i still cant enter the game.
I have applied all the fixes posted in the forums about a week before.
So what now, i have the fault report saved how do i upload it.

#7 [en] 

how do you get to game configuration or remove the checkmark in the micro-vegetation...
if you could even tell me how to find the game configuration or micro-vegetation it would help alot.

i cant login with any of the characters

Last edited by Tronjon(arispotle) (10 years ago)

#8 [en] 

Hi Tronjon,

How to edit the game configuration is explained in my first post.

Last edited by Sywindt(Yubo) (10 years ago)


Sywindt | Game Master | EN, NL, de, fr

#9 [en] 

yea so tried all these so called fixes.... and none of it works! everytime i try to play it loads.. bar goes around and then it freezes or locks up and thats it..... really awesome right>? guess what im deleting this game and never playing it ..... all this bull crap about fixes and stuff goes on forever... users shouldnt have to be editing this and that to make it work.... not at all happy about the game . good thing i didnt pay for a subscription then eh (funny how that wasnt mentioned in the read up .. said it was 100% free..... isnt that lie )
well enjoy your endeavours in making useless and malfunctioning games.... !!

#10 [en] 

Sorry your having some problems kayfour
Perhaps you could email with some details about your computer specifications operating system etc we may be able to help get the game going.

#11 [en] 

I'm getting disconnected every few minutes, it's almost impossible to play. I can still log in with my char.

This fixes don't help at all. Any suggestion?

#12 [en] 

I don't think that had to do with Mac. It happened to me, too, at about the same time as you posted. I think there was a funky link somewhere on the internets. I'm on the West Coast USA, but a friend in Texas was having no problems.


Remembering Tyneetryk
Phaedreas Tears - 15 years old and first(*) of true neutral guilds in Atys.
(*) This statement is contested, but we are certainly the longest lasting.
<clowns | me & you | jokers>

#13 [en] 

I do think it's not Mac-related as well, nor my internet. I guess the problem could be server-side, cuz now I am able to play again with no config changes.
Anyway, thank you.

#14 [en] 

West coast problems and Texas none?

Maybe there was a problem with the backbone through central US or it was just clogged...

The servers are in France (Europe) so you'll have to go from your place to the east coast and from there through the sea cable to Europe...

A nice overview of a lot of backbones can be found here: y/atlas/more_isp_maps.html
Most backbone extensions are done along existing routes so the maps might not show the right bandwidths but they have the right routes.
Here are some weathermaps with live data for OVH (the provider where the servers stood when I last checked)

If you have connection problems with ryzom again try to check the route to the ryzom servers.
Linux / Unix
Windows Vista and higher
Windows XP
This will show you where the issue is (it shows the ping of each node on the route)
If it's the case that there is an extremly high ping somewhere in the route and it's something outside the network of OVH you'll have to complain to your own ISP otherwise tell the CSRs that they should complain to OVH or just wait a little while and test again.

Last edited by Sywindt(Yubo) (9 years ago) | Reason: fixed servers


#15 [en] 

Hi my Ryzom app won't even open now :( i click its icon, it animates, but then stops.... I don't get an error message or a crash report...

I opened the client itself and console gave me this info:

Last login: Tue Dec 3 13:25:46 on console
Rays:~ Ray$ /Applications/ ; exit;
Parse error on the "/Users/Ray/Library/Containers/com.winchgate.Ryzom/Data/Libr ary/Application Support/Ryzom/client.cfg" file, line 54

[Process completed]

I know there can be problems with the config files, but they're hard to find on a mac and don't know exactly what to do when i do find them....
Last visit Tue Jun 22 17:45:12 2021 UTC

powered by ryzom-api