English French German Spanish Russian
[FIXED] img tag crashes client - Web Apps - Ryzom Community ForumHomeGuest

Web Apps


uiWebPrevious12uiWebNext

#16

Now they have added checking of image size but the check does not work. Won’t let me change my avatar to a new one I made that is 64x128 even though it says that’s valid.

UPDATE: Correction. The checking is fine, just the message was misleading. If I use a non-existent file name it should tell me that instead of complaining about the size.

#17

Sweetmarie (Arispotle)
I used...

http://heartsofthunder.openlink.pl/images/myGallery/Stun.JPG

"Avatar image needs to be in PNG format and preferable size of 64x64 or 64x128 (width / height must be 32, 64 or 128 pixel)."
Sorry, i don't speak english very well (i'm french ^^) but your image format isn't the good format

Try to change JPG in PNG with The Gimp or Photoshop

#18

Just now I decided to risk using these forums in game again (they were causing me to have a client crash often).

First thing I did was open the Official Spankings Thread in the public forum… Crashed immediately.

#19

I have no problems with that thread. Does anybody else crash there?

Sweetmarie: you can try deleting all files newer than 2 days in your Ryzom\cache folder.

---

Sywindt | Game Master | EN, NL, de, fr

#20

Deleted cache files, opened Official Spanking Thread… Death to client.

#21

We changed the way to handle images.
Can you tell me if you still have problem? and if yes, can you describe exactly how to reproduce it.

Thanks for your report!

#22

Vaielle (Aniro)
We changed the way to handle images.

Great, works nicely here =)

---

Kaetemi

#23

Vaielle (Aniro)
Can you tell me if you still have problem?
This one does not display when putting it between the img tags:
http://dl.kaetemi.be/kaetemi/ryzom/wanadoo_fyros_front.png (*EDIT: this one works now*)
(the image proxy seems to be broken on vertical(portrait) images in png format, or it has something to do with filesize)

Works:
http://blog.kaetemi.be/public/mi sc/.toren_m.jpg
Does not work:
http://blog.kaetemi.be/public/misc/toren.png

---

Kaetemi

#24

Kaetemi (Arispotle)
Works:
http://blog.kaetemi.be/public/mi sc/.toren_m.jpg
Does not work:
http://blog.kaetemi.be/public/misc/toren.png
jpg is ~200K, png is ~4M.... just use jpg ;-)

---

Hello!

#25

Ok testing the same image that was crashing my client...


No crash so far :)

Not very good though since it displayed a partial image until i re-opened, then showed the complete image, then another try shows only the "X", but at least no crash.

UPDATE: reason for the "x" showing after a few tries is that a space was inserted (not by me) in the url after an edit.

(Edit again.. space goes back in so easy to recreate.)


Also the other thread that was crashing me no longer does. I have put the image back in there too.



So now that I have been your beta tester, could you plz fix my MPA? :)
uiWebPrevious12uiWebNext
 
Last visit Thu Aug 22 17:35:18 2019 UTC
P_:

powered by ryzom-api