English French German Spanish Russian
Paid for sub got nothing - Technical Support - Ryzom Community ForumHomeGuest

Technical Support


uiWebPrevious1uiWebNext

#1 [en] 

Hello!
I paid with Paypal for a sub but my billing account say "free trial".
Under account events the sub is showing as paid with Paypal with an event ID.
So It's paid but not activated.
I contacted support but no answer until now.
No problem...It was just for one month to test ^^
Game look fun but everything else seems bugged or archaic.
So have fun everyone,I'm already subbed to EQ2 and LOTRO...maybe It's a sign that I don't need another MMO on my SSD...

#2 [en] 

Problem solved.

Thanks a lot :)
I come from Steam...I didn't wanted to link another thing to Steam and used the old way to play.
I'm sorry to say that your forum and subscription system is very outdated...when you are a new player It's not easy to navigate and figure out how It work.
I mean you need to think 1999 ^^
I hope It's not a too big turn-off to get new citizen in your world because the game itself is great!

#3 [en] 

I'm sorry to say that your forum and subscription system is very outdated...when you are a new player It's not easy to navigate and figure out how It work.

Don't be sorry.. the subscription system are very outdated and we work to improve it a lot !

#4 [en] 

Ulukyn
I'm sorry to say that your forum and subscription system is very outdated...when you are a new player It's not easy to navigate and figure out how It work.

Don't be sorry.. the subscription system are very outdated and we work to improve it a lot !

Good Luck then ^^
I suppose It's going to take lot of hard work.
uiWebPrevious1uiWebNext
 
Last visit Fri Apr 10 02:32:30 2020 UTC
P_:

powered by ryzom-api