English French German Spanish Russian
Public release with debug? - General - Ryzom Community ForumHomeGuest

General


uiWebPrevious1uiWebNext

#1 [en] 

Did someone build the public release with debug on?

I keep getting my log (which the game refuses to let me turn off btw)
filled with the following till it completely fills my drive.

"2017/02/17 20:42:43 DBG 10b4 ryzom_client_r.exe driver_opengl_texture.cpp 103 NL3D::CDepthStencilFBO::CDepthStencilFBO : 3D: Init shared FBO
2017/02/17 20:42:43 DBG 10b4 ryzom_client_r.exe driver_opengl_texture.cpp 194 NL3D::CTextureDrvInfosGL::initFrameBufferObject : 3D: glFramebufferRenderbufferExt(depth:24) = 8CD6
2017/02/17 20:42:43 DBG 10b4 ryzom_client_r.exe driver_opengl_texture.cpp 197 NL3D::CTextureDrvInfosGL::initFrameBufferObject : 3D: glFramebufferRenderbufferExt(stencil:8) = 8CD6
2017/02/17 20:42:43 WRN 10b4 ryzom_client_r.exe driver_opengl_texture.cpp 226 NL3D::CTextureDrvInfosGL::initFrameBufferObject : Framebuffer incomplete attachment
2017/02/17 20:42:43 DBG 10b4 ryzom_client_r.exe driver_opengl_texture.cpp 145 NL3D::CDepthStencilFBO::~CDepthStencilFBO : 3D: Release shared FBO"

#2 [en] 

Herrah
I keep getting my log (which the game refuses to let me turn off btw)
filled with the following till it completely fills my drive.

Backup your current client.cfg and then remove all lines except 'RootConfigFilename' and see if it still happens.

---

Hello!

#3 [en] 

I will try that thanks.
It is the default fresh install config btw.
No edits happened to it prior to the log explosion.

Oh also, it doesn't happen right away. Usually takes a number of hours before it starts happening.

Last edited by Herrah (2 years ago)

#4 [en] 

Ran for a few hours and it started up again.
I am now getting multiple 5mb log files with numbers appended.
All filling with the same lines previously posted.

Still the client won't accept a log shut off. If I try, it patches the config and restarts client.

#5 [en] 

I am asking myself the same about a debug version of the client,
Or maybe just missing some define in compilation,...
It's not the first time we see DBG log post on the forum.

But, at least after a very quick look on the source file, it doesn't seem that those line are because of any error but more likely some kind of "check" print for debug purpose.

Look like it's creating/detroying framebuffer, does it happend when you take a screenshot or something like that ?

Edited 2 times | Last edited by Osquallo (2 years ago)

---

Osquallo
Les rĂªveries du yubo flaneur
The musings of the rambling yubo

#6 [en] 

Herrah
Ran for a few hours and it started up again.
I am now getting multiple 5mb log files with numbers appended.
All filling with the same lines previously posted.

Still the client won't accept a log shut off. If I try, it patches the config and restarts client.

If you want to make edits to client_default.cfg, then copy only those lines to client.cfg, Do not copy everything.

Seeing DBG on startup is normal. They will be turned off really early.

Seeing DBG after few hours of play is not. Is there log.log file also that gets updated?

---

Hello!

#7 [en] 

I never take any screenshots. This mostly happens just in normal play and if running idle.

The normal debug messages do get logged for a bit but yes those stop. It is just the lines that I pasted that repeat over and over. I only saw log.log once and didn't pay any attention to it as it doesn't get huge and it didn't dawn on me to look it over closely.

If it happens again and that file pops up I'll look that over too.

I have not figured out where/how to compile the current code as every one of my old links I used years ago is either lacking info or dead links. Otherwise I'd help troubleshoot this.

For some odd reason, any edits I do the the cfg files prompts a patch over write. Aside from wiping out the cfg file leaving only that one line suggested earlier. All other changes get reverted.
uiWebPrevious1uiWebNext
 
Last visit Sun Dec 16 05:28:38 2018 UTC
P_:

powered by ryzom-api