English French German Spanish Russian
Ryzom On 64bit Linux Boxes - Hope This Helps - Mutual GNU / Linux - Ryzom Community ForumHomeGuest

Mutual GNU / Linux


uiWebPrevious12uiWebNext

#16 [en] 

Just FYI, I'm on 64-bit Ubuntu 14.04 and installed Ryzom package from Software Center. Works like a charm but sometimes water is rendered black and reflects animation on the sky. This is pretty annoying in Aedan Aeden Aqueous but since I'm in Verdant Height it does not bother me much.

---

#17 [en] 

I'd try to update the GPU driver. I have the same Ubuntu version and installed Ryzom same way, but I don't have such issue. I had some graphics issues after changing to newer video card driver, but reboot helped.

---

I don't want to be the one
The battles always choose
'Cause inside I realize
That I'm the one confused

#18 [en] 

You can try the ppa version :
sudo add-apt-repository ppa:ryzom-isv/ppa
sudo apt-get update && apt-get install ryzom

---

Ducocinnio Nono, dit Duke Nono
Noble Matis, artisan de la maison noble La Firme
Gardien du Royaume et Béni de Jena

#19 [en] 

It's essential that you do select the "Driver Manager" in the System Setting and, at the minimum you update your graphics drives to the recommended version and ensure that you are actually runing that version. The native drivers in Ubuntu are not sufficient.

Last edited by Teeneemai (3 years ago)

#20 [en] 

Topic should be unstickied, as there are now official 64 bits client, no need to run a 32 bits client on a 64 bits architecture anymore.

---

#21 [en] 

I recently re-installed 16.04 ubuntu LTS on my Asus desktop and now I can't seem to get Ryzom to launch successfully. It launches and then disappears. Any suggestions would be great.
Config file is
LanguageCode = "en";
SaveConfig = 1;
Driver3D = "OpenGL";
FullScreen = 0;
Width = 0;
Height = 0;
PositionX = 0;
PositionY = 0;
ProcessPriority = -1;
LandscapeTileNear = 50.0000000000;
LandscapeThreshold = 1000.0000000000;
Vision = 500.0000000000;
MicroVeget = 1;
MicroVegetDensity = 80.0000000000;
FxNbMaxPoly = 20000;
Cloud = 1;
CloudQuality = 160.0000000000;
CloudUpdate = 1;
Shadows = 1;
FXAA = 1;
Bloom = 1;
SquareBloom = 1;
DensityBloom = 255.0000000000;
SkinNbMaxPoly = 100000;
NbMaxSkeletonNotCLod = 125;
CharacterFarClip = 200.0000000000;
ForceDXTC = 1;
DisableVtxProgram = 0;
DisableVtxAGP = 0;
DisableTextureShdr = 0;
HDEntityTexture = 1;
SoundForceSoftwareBuffer = 1;
SoundOn = 0;
MaxTrack = 4;
DriverSound = "Auto";

and log.log is

#22 [en] 

Landar
I recently re-installed 16.04 ubuntu LTS on my Asus desktop and now I can't seem to get Ryzom to launch successfully. It launches and then disappears.
run from terminal to see what the problem might be

---

Hello!

#23 [en] 

Log Starting [2017/10/27 22:38:57]
2017/10/27 22:38:57 DBG 435500992 ryzom_configuration_qt driver_opengl_window.cpp 370 init : 3D: XOpenDisplay on ':0' OK
2017/10/27 22:38:57 INF 435500992 ryzom_configuration_qt driver_opengl_window.cpp 381 init : 3D: XRandR 1.5 found
2017/10/27 22:38:57 INF 435500992 ryzom_configuration_qt driver_opengl_window.cpp 392 init : 3D: XF86VidMode 2.2 found
2017/10/27 22:38:57 INF 435500992 ryzom_configuration_qt driver_opengl_window.cpp 406 init : 3D: XRender 0.11 found
2017/10/27 22:38:57 DBG 435500992 ryzom_configuration_qt driver_opengl_window.cpp 410 init : 3D: Available X Extensions:
3D: Generic Event Extension SHAPE MIT-SHM XInputExtension XTEST
3D: BIG-REQUESTS SYNC XKEYBOARD XC-MISC SECURITY
3D: XFIXES RENDER RANDR XINERAMA Composite
3D: DAMAGE MIT-SCREEN-SAVER DOUBLE-BUFFER RECORD DPMS
3D: Present X-Resource XVideo XVideo-MotionCompensation XFree86-VidModeExtension
3D: XFree86-DGA DRI2 GLX SGI-GLX
2017/10/27 22:38:57 DBG 435500992 ryzom_configuration_qt config_file.cpp 408 reparse : CF: Adding config file '/home/reid/.local/share/Ryzom/0/client.cfg' in the config file
2017/10/27 22:38:57 INF 435500992 ryzom_configuration_qt config_file.cpp 483 reparse : CF: RootConfigFilename variable found in the '/home/reid/.local/share/Ryzom/0/client.cfg' config file, parse the root config file '/home/reid/.local/share/Ryzom/ryzom_live/client_default.cfg '
2017/10/27 22:38:57 DBG 435500992 ryzom_configuration_qt config_file.cpp 408 reparse : CF: Adding config file '/home/reid/.local/share/Ryzom/ryzom_live/client_default.cfg ' in the config file
2017/10/27 22:38:57 DBG 435500992 ryzom_configuration_qt config_file.cpp 408 reparse : CF: Adding config file '/home/reid/.local/share/Ryzom/ryzom_live/client_default.cfg ' in the config file

#24 [fr] 

did you checked your graphic card driver ?

---

#25 [en] 

yes I believe it is functioning properly I can watch videos and seem to be working fine. I have tried both Auto and Open GL config and both give the same results. if you have a suggestion let me know.

#26 [en] 

I did check the Asus website for drivers specific for linux but I couldn't find any. I am running an Asus desktop M32 BC

#27 [en] 

going to re-install stay tuned :)

#28 [en] 

If everything else fails, try a single folder installation:

https://app.ryzom.com/app_forum/index.php?page=post/view/174995

I got that running on a variety of boxes when installed on usb disk or stick without any troubles. Sometimes, some library may be reported missing, but apt-cache search or so will help.

---

Daomei die Streunerin - religionsneutral, zivilisationsneutral, gildenneutral
uiWebPrevious12uiWebNext
 
Last visit Sun Jun 24 06:43:51 2018 UTC
P_:

powered by ryzom-api