English French German Spanish Russian
Terribly slow "mouse look" - TECHNICAL SUPPORT / WEB APPs BUGS - Ryzom Community ForumHomeGuest

TECHNICAL SUPPORT / WEB APPs BUGS


uiWebPrevious1uiWebNext

#1 Report | Quote[en] 

Okay so a feature in the game is to have free look by clicking on the screen and dragging with your mouse. When I first ran the game this worked just fine, however now it starts off with "normal" speeds and then slows down terribly. It's not my graphics because everything else moves at normal speed even while looking around. Tried different mouse configs and nothing helps (checked the hardware box). This does not apply to one character but all characters so it's not the character config files. Tried deleting the general config files and it didn't work. The only left to do is delete the entire .ryzom home directory (using Ubuntu) and redownload all that data (ughh!!!). This also has no change effect switching from fullscreen to window mode (tried that too). Any advice or help out there?

#2 Report | Quote[en] 

It happens to me everytime I let my toon idle for some time, and when I come back and try to free look it lags as hell. After ~30 seconds it returns to normal.

Last edited by Dinorath (7 years ago)

#3 Report | Quote[en] 

See my problem is it's not returning to normal at all. I can give it more time and see what happens though. However if there is any other advice I'd appreciate it. And thank you so much for a quick response Dinorath.

#4 Report | Quote[en] 

This is a really odd problem. Apparently it's only happening in Ubuntu/Linux (Haven't tried any other distros to confirm) with my Razer Naga Mouse. In Windows the Razer is fine and in Ubuntu my trackpad and Logitech mouse are fine.

I've also confirmed this problem because a friend who uses Ubuntu, the Razer Naga and plays Ryzom reports the same problem.

Really odd that it's just this mouse and Ubuntu. All other games and applications inside Ubuntu work fine with this mouse so it's not a kernel DPI setting, I've already thought about that, unless Ryzom changes DPI settings in Ubuntu?

And this isn't really a lag. What is does is starts off really fast and then about a half second in it just slows down big time.

Edited 2 times | Last edited by Efeeko (7 years ago)

#5 Report | Quote[en] 

Okay I just tried changing the mouse polling thinking that might help. It did not help with this particular problem in Ryzom.

By the way to change mouse polling in Ubuntu:

sudo nano /etc/modules (nano or the editor of your choice, for gui gedit)
-r usbhid
usbhid mousepoll=n

Then reboot.

n Legend:
1 = 1000Hz
2 = 500Hz
4 = 250Hz
8 = 125Hz
10 = 100Hz (Default)

You can test that you have done this correctly by: cat /sys/module/usbhid/parameters/mousepoll

#6 Report | Quote[en] 

Not sure if you found a solution or not, but I noticed the same thing when I first started playing in Ubuntu. I managed to resolve this by doing the following:
System -> Game Configuration -> Input -> Mouse
Slide Head Speed and Head Acceleration all the way to the right.
Click OK/Apply.

I hope that works for you too.

#7 Report | Quote[en] 

It helped a little but it didn't really fix the problem. I suppose since I also play in Windows I might be a bit more sensitive to this issue. Probably going to be the last Razer item I buy due to terrible Linux support.

#8 Report | Quote[en] 

I think it actually may have less to do with the mouse and more to do with OpenGL vs DirectX.

I've noticed that if I use the config utility to tell the game to run directx, I don't get the bogged down mouse look, but if I change it to OGL, I do. (both in Windows 7)

I still run it in OGL mode, simply because I like the way OGL handles alt-tabbing better than directx does. I've just learned to live with the slow mouse look once in a while.

---

uiWebPrevious1uiWebNext
 
Last visit Wed Jul 17 15:16:11 2019 UTC
P_:

powered by ryzom-api