English French German Spanish Russian
Patcher after login screen kills game files finally - TECHNICAL SUPPORT / WEB APPs BUGS - Ryzom Community ForumHomeGuest

TECHNICAL SUPPORT / WEB APPs BUGS


uiWebPrevious1uiWebNext

#1 Report | Quote[en] 

Good daytime to you,
I was playing Ryzom ~3 months without any problems, last version was 1.13, but game client suddenly died.

What happened:
Today I started game as always, after login screen it checked game files and offered me to install new patch. I checked game forums and didn't found any info about new patches. After patch was completed (or not completed, I don't know) game hanged and hanged PC. After PC was restarted, I started game again and got same symptoms, it was trying to apply some strange patches v1.12 and earlier, game was finally broken absolutely. After all game said about fatal error and crashed to desktop even not loaded login screen.

What I tried to do:
Few times I uninstalled game and made clean install of it. Last patches was applied normally, I was entering game and was able to play - untill exit. Every time at next start after clean install, playing and exit - problem was same. Game was trying to apply some "new patches" and was hanging PC or killing game files. Also I tried to copy game files from another PC (where all works and continue working), but was getting same problem. Few times before clean install I tried to clean out OS registry from any Ryzom's keys. Problem still present and I don't know what to do more.

Parameters of PC:
» QuadCore Intel Core 2 Quad, 3000 MHz
» Motherboard Gigabyte GA-EP45-UD3R
» 3584 MB of RAM
» PCI-E Video card ATI Radeon X1550 (RV516) PCI-E
» PCI Creative Audigy 2 ZS (SB0350) Sound Card

Parameters of OS and drivers:
» x86 Microsoft Windows 7 Ultimate SP1 (6.1.7601)
» DirectX 11.0
» all video and sound drivers installed

Dear CSRs (or ppl with same problem), pls I need your help.
 

#2 Report | Quote[en] 

Hey Sun, sorry to hear that.

Something like this happens when ryzom detects changes to some of its program or data files. The patcher checks for the last patch that contains the changed file and installs it. afterwards it needs to install all subsequent patches to restore the game (in theory). This procedure sometimes breaks, but the real question is why are changes detected by the patcher in the first place.

In most cases some application (antivirus, virus) has altered files or the harddisc is about to die (you should have issues with other windows programs too if that is the case). :(

Ryzom relies on the files in ryzom game folder only. You can try to copy it to another harddisc or usb memory stick to make sure the harddisc is ok.

I hope you get it fixed soon!

#3 Report | Quote[en] 

ty, my friend, now checking my PC with scanners I was able to get, after that i'll check HDDs too

Last edited by Sunflare (arispotle) (7 years ago)

#4 Report | Quote[en] 

Also, maybe run a RAM test, if this isn't already in your list of scanners. I installed some bad RAM once, and while my system would still run, for a short while... whenever stuff was transferred from RAM to HDD it would corrupt, eventually causing my system to die (within 1-4 hours after format). Does sound like a part of your ryzom directory is being corrupted though.

#5 Report | Quote[en] 

Checked RAM, HDDs, scanned for viruses (with 7 diff scanners), cleaned registry, re-installed game software few times. Result was same, only re-install of OS solved the problem. Idk for what time.

#6 Report | Quote[en] 

I have had similar problems off and on...what I do to prevent them now is make a complete backup of the program directory. If the silly thing crops up, I just replace the current directory with the backup (I don't replace the save directory so I can maintain my map markers and macros). Simple fix for an annoying problem but I have no idea what goes wrong with the installation in the first place.

Edit
Just reread your post Sunflare and realized you had basically done this already.

Last edited by Gorran (7 years ago)

---

No guild. No fame.
Gorran is my name.

uiWebPrevious1uiWebNext
 
Last visit Wed Jun 19 17:29:42 2019 UTC
P_:

powered by ryzom-api