English French German Spanish Russian
Installation sous Debian impossible - TECHNICAL SUPPORT / WEB APPs BUGS - Foro de la Comunidad RyzomInicioInvitado

TECHNICAL SUPPORT / WEB APPs BUGS


uiWebPrevious1uiWebNext

#1 Reportar | Citar[fr] 

Bonjour,

Je suis sous Debian et comme pour Terregaia j'ai eu une difficulté en installant Ryzom : https://app.ryzom.com/app_forum/index.php?page=topic/view/29877/4 #4

J'ai cliqué sur le lien de Moniq et j'ai glissé le dossier ryzom_live_data avec l'installeur.

J'ai toujours le même soucis de code erreur status 0.

Peut-être ai-je mal compris l'explication de Moniq ?

Merci pour votre retour. :)

#2 Reportar | Citar[fr] 

Suite au message précédent, j'ai continué mes pérégrinations et je suis tombé là dessus (https://app.ryzom.com/app_forum/index.php?page=post/view/193906) .

J'ai donc suivi ce qui était indiqué là dessus (https://en.wiki.ryzom.com/wiki/Ryzom_Installer_Manual#Error_307_ .26_Error_0_.26_.22.22File_is_larger_than_expected.22.22) (il dit la même chose en français : https://fr.wiki.ryzom.com/wiki/Manuel_de_l'installeur_Ryzom# Version_Linux_de_l.27Installateur_Ryzom) puis je suis encore tombé sur une erreur 0, où il manquait l'installeur.

Je l'ai donc aussi téléchargé, selon la même procédure pour le mettre dans le même dossier.

Encore une erreur 0, avec cette fois un problème de fichier cfg. Lui, je ne sais pas encore où le trouver. :/

Je reste à l'écoute. :)

Última edición por Saperlipop (4 months hace)

#3 Reportar | Citar[fr] 

Bonjour, tu télécharges et unzip ce dossier:
https://download.ryzom.com/ryzom_live_client_linux64.7z
Puis tu unzip dedans https://download.ryzom.com/ryzom_live_data.7z dans un dossier "data"

#4 Reportar | Citar[fr] 

Deed
Bonjour, tu télécharges et unzip ce dossier:
https://download.ryzom.com/ryzom_live_client_linux64.7z
Puis tu unzip dedans https://download.ryzom.com/ryzom_live_data.7z dans un dossier "data"

Bonjour Deed et merci pour ton retour ! :)

Comme je n'étais pas sûre de bien comprendre, j'ai testé deux choses :

- dans le dossier /home/.local/share/ryzom/ j'avais un dossier ryzom_live dans lequel j'ai, dans le dossier data, dézippé l'archive ryzom_live_data.7z
- toujours dans /home/.local/share/ryzom/, j'ai dézippé la première archive, puis, comme indiqué, j'ai dézippé ryzom_live_data.7z dans un dossier intitulé "data"

Lorsque je passe par le lanceur d'application, mon problème de cfg manquante pour Atys est toujours là, avec le code erreur 0.

Última edición por Saperlipop (4 months hace)

#5 Reportar | Citar[fr] 

Je te conseille de créer un dossier /home/ton-user/ryzom/
et de décompresser dedans puis de lancer ryzom_client

#6 Reportar | Citar[fr] 

Re ! Merci encore pour ton retour !

J'ai donc un dossier /home/moi/ryzom/, avec le dossier dézippé de ryzom_live_client_linux64.7z

Apparaissent donc dans /home/moi/ryzom/ le client ryzom_client, l'installeur , ryzom_configuration_qt ...

Mais aussi, le dossier dézippé de ryzom_live_data.7z renommé en data parce qu'il fallait le tout dans un dossier data, si j'ai bien compris tes propos.

En cliquant sur le client, de nouveaux fichiers sont apparus (cela me semble normal), mais rien ne s'est lancé.

En cliquant sur le programme de config, une fenêtre de config s'est ouverte, puis en cliquant sur lancer le jeu, rien ne se passe.

En cliquant sur l'installeur, j'ai encore le problème de code statut 0 avec le cfg requis pour Atys.

Peut-être est-ce un souci avec la configuration de ma Debian ?

Ah. Dans la version driver de ma carte graphique je vois noté 0.0.0.0 - serait-ce là le soucis ? Pourtant je vois les vidéos en ligne sans problèmes, et je peux jouer à 0.A.D, par exemple (quoi que ce dernier n'est pas fluide).

Merci encore pour les retours !

#7 Reportar | Citar[fr] 

essaye de mettre des droits

chmod -R ug+RW ryzom

Si ça ne fonctionne pas :
tu dois avoir un fichier de Nel_***.log ou client.log.

Il me faut les lignes à la fin avec l' ERROR
s'il te plait

#8 Reportar | Citar[fr] 

Deed,

Je ne l'ai pas fait. En revanche, j'ai tenté d'installer des drivers plus en adéquation avec ma carte graphique, et le client s'ouvre.

Je suis perplexe. :/

Actuellement, le client télécharge le patch 4583.

#9 Reportar | Citar[fr] 

Et bien, après avoir fait ce téléchargement de patch, le client demande une nouvelle identification, la valide, affiche une image, lance un début de musique d'ambiance et une seconde plus tard s'éteint sans crier gare.

Voici ce qui s'affiche dans le fichier de log :
Log Starting [2020/03/08 19:19:24]
2020/03/08 19:19:24 DBG 2639906752 ryzom_configuration_qt driver_opengl_window.cpp 370 init : 3D: XOpenDisplay on ':0' OK
2020/03/08 19:19:24 INF 2639906752 ryzom_configuration_qt driver_opengl_window.cpp 392 init : 3D: XF86VidMode 2.2 found
2020/03/08 19:19:24 INF 2639906752 ryzom_configuration_qt driver_opengl_window.cpp 406 init : 3D: XRender 0.11 found
2020/03/08 19:19:24 DBG 2639906752 ryzom_configuration_qt driver_opengl_window.cpp 410 init : 3D: Available X Extensions:
3D: Generic Event Extension SHAPE MIT-SHM XInputExtension XTEST
3D: BIG-REQUESTS SYNC XKEYBOARD XC-MISC SECURITY
3D: XFIXES RENDER RANDR XINERAMA Composite
3D: DAMAGE MIT-SCREEN-SAVER DOUBLE-BUFFER RECORD DPMS
3D: Present DRI3 X-Resource XVideo XVideo-MotionCompensation
3D: XFree86-VidModeExtension XFree86-DGA DRI2 GLX SGI-GLX

2020/03/08 19:19:24 DBG 2639906752 ryzom_configuration_qt config_file.cpp 408 reparse : CF: Adding config file '/home/moi/ryzom/client.cfg' in the config file
2020/03/08 19:19:24 INF 2639906752 ryzom_configuration_qt config_file.cpp 483 reparse : CF: RootConfigFilename variable found in the '/home/moi/ryzom/client.cfg' config file, parse the root config file '/home/bigdo/ryzom/client_default.cfg'
2020/03/08 19:19:24 DBG 2639906752 ryzom_configuration_qt config_file.cpp 408 reparse : CF: Adding config file '/home/moi/ryzom/client_default.cfg' in the config file
2020/03/08 19:19:24 DBG 2639906752 ryzom_configuration_qt config_file.cpp 408 reparse : CF: Adding config file '/home/moi/ryzom/client_default.cfg' in the config file

#10 Reportar | Citar[fr] 

Je ne vois pas d'erreur dans les logs.

j'installerai d'autre lib comme :

apt install libcurl4-openssl-dev libluabind-dev libfreetype6-dev libx11-dev libgl1-mesa-dev libxxf86vm-dev libxrandr-dev libxrender-dev libopenal-dev libogg-dev libvorbis-dev libxml2-dev libpng12-dev libjpeg62-turbo-dev libmysqlclient-dev bison libxmu-dev liblzma-dev libgif-dev libssl-dev libavdevice-dev

Última edición por Deed (4 months hace)

#11 Reportar | Citar[fr] 

Un conseil:
1. coupe le son (du jeu) via ryzom_live/ryzom_configuration_qt
2. lance ryzom en ligne de commande (on voit mieux les messages d'erreur)


https://fr.wiki.ryzom.com/wiki/Installer_Ryzom#GNU_et_linux

Editado 3 veces | Última edición por Craftjenn (4 months hace)

#12 Reportar | Citar[fr] 

Bonjour Saperlipop,
qu'elle distribution Debian utilises tu ?
Chez moi Ryzom tourne parfaitement sur Debian 9 'stretch' et sur Debian 10 'buster'. Sur Debian 10 je crois même si je me souviens qu'il n'est même pas nécessaire d'installer d’autres librairies annexes pour le faire tourner. J'ai installé également les drivers nvidia pour ma carte video, mais ce n'est pas ça qui empêche le jeu de se lancer.

C'est vrai que je l'ai installé à la main sans l'aide de l'installateur, comme indiqué plus haut dans un répertoire /home/xxx/Jeux/ryzom en décompressant les deux fichiers indiqués. Je le lance simplement dans une fenêtre de commande en me plaçant dans le répertoire /home/xxx/Jeux/ryzom et je tape:
./ryzom_client

Última edición por Eolinius (4 months hace)

uiWebPrevious1uiWebNext
 
Last visit lun 13 jul 2020 21:02:52 UTC UTC
P_:

powered by ryzom-api