English French German Spanish Russian
Won't run on GNU - Mutual GNU / Linux - Foro de la Comunidad RyzomInicioInvitado

Mutual GNU / Linux


uiWebPrevious1uiWebNext

#1 [es] 

Hi, I trying to run Ryzom on GNU("Trisquel7 64" Ubuntu-like) with latest Linux version. All of 3 methods failed. The one from added repository, worked with a huge bug, that bug keeps adding "Noexists:ui" before all texts in client/game, for example: "Noexists:uiRyzom", or play button "Noexists:uiPlay". After that, Ryzom keeps stucked at loading screen, playing music, but never pass the loading screen.

Hardware: Thinkpad x200t, c2d SL9400, 4gb ddr3, gpu Intel 4500mhd.

Thinkpad T400, c2d T9600, 8gb ddr3, gpu Intel 4500mhd.

Both with same software.

Editado 2 veces | Última edición por Vitacell (3 years hace)

#2 [en] 

did you try to use the binary from ryzom's website ?

---

Ducocinnio Nono, dit Duke Nono
Noble Matis, artisan de la maison noble La Firme
Gardien du Royaume et Béni de Jena

#3 [es] 

Yes, the sourceforge's one, update and client won't work. I tryed to run from console with root too.

As I said, from repository, it does work, but stucks at loading screen (after pushed the "play" button in client).

Última edición por Vitacell (3 years hace)

#4 [en] 

Try to download this file : ryzom_client_static_full_linux64_3.0.0.7578.7z from http://ryzom.kervala.net/clients/
There is all inside...

edit : bad file
edit 2 : try to run ryzom_client from terminal to be sure that you have all libraries installed.

Editado 2 veces | Última edición por Dukenono (3 years hace)

---

Ducocinnio Nono, dit Duke Nono
Noble Matis, artisan de la maison noble La Firme
Gardien du Royaume et Béni de Jena

#5 [es] 

1-I tryed you suggested. Bash prints:

bash: /home/vita/ryzom/ryzom_client: No such file or directory

It was a 32bits problem, because I use 64, so, installed "libc6-i386". Solved.

Now console prints:

root@vita-ThinkPad-X200T:/home/vita# /home/vita/ryzom/ryzom_client
/home/vita/ryzom/ryzom_client: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Do I need install 32bits packages? libgl1-mesa-glx?

#6 [en] 

Vitacell
Do I need install 32bits packages? libgl1-mesa-glx?
If you want to use 32bit version, then you need to install a lot of 32bit packages.

If you want to use 64bit, then you can grab 64bit version from http://ryzom.kervala.net/clients. There is both binary only and full download available.

If you using packaged version, then it should install 64bit version already that you can find under /opt/ryzom I believe

---

Hello!

#7 [en] 

The file I was talking about is for 64bits system. Did you removed older packages from repository ?
On Xubuntu, I only needed to install a sound lib to get no error launching the game with ./ryzom_client command in a terminal (in the good directory).

---

Ducocinnio Nono, dit Duke Nono
Noble Matis, artisan de la maison noble La Firme
Gardien du Royaume et Béni de Jena

#8 [es] 

I am using Lubuntu. I have been playing about a year.

The last month I keep crashing. I am running 32bit and was 32 bit install.

I have updated all my software. I am still crashing.

I am getting a new isp on next Thursday, June 23, 2016. I am going to see about reinstalling everything then.

---


The Clan


#9 [es] 

So if I understand, it was working fine till one month, and then no more? Is it?
If it is so, do you remember what has changed at that time? CGU update, garphical libraries?
And when is it crashing? When starting? when choosing a toon? after?

And reading more ahead the post I see ~/ryzom/ryzom_client no such file. Did you check the presence of that file AND the good rignts for the execution? (Sorry if the question is stupid... but everybody can forget something ;) )

Última edición por Zorroargh (3 years hace)

---

Zo'ro Argh
Chargé de recherche dans la guilde du Cercle du Bois d’Almati.
Ambassadeur des Rangers auprès des Matis.
Président de la N’ASA et fondateur de Hoodo.

#10 [es] 

ty zorroargh checking, checking :)

---


The Clan


#11 [en] 

Karu
Vitacell
Do I need install 32bits packages? libgl1-mesa-glx?
If you want to use 32bit version, then you need to install a lot of 32bit packages.

If you want to use 64bit, then you can grab 64bit version from http://ryzom.kervala.net/clients. There is both binary only and full download available.

If you using packaged version, then it should install 64bit version already that you can find under /opt/ryzom I believe

UNZIPPED: "ryzom_client_static_full_linux64_3.0.0.7578.7z", from this link, and everything running out of the box.
uiWebPrevious1uiWebNext
 
Last visit dom 18 ago 2019 17:01:57 UTC UTC
P_:

powered by ryzom-api