English French German Spanish Russian
Ryzom FV 2.1.0.6447 fails to start - Mutual GNU / Linux - Ryzom Community ForumHomeGuest

Mutual GNU / Linux


uiWebPrevious123uiWebNext

#31 [en] 

I'm not running the client directly. I posted the results I get when clicking on the icon, when starting the .sh script, and when starting the client directly. When you asked me to post the log, I started Ryzom from the icon.

Last edited by Sennuri (3 years ago)

#32 [en] 

Can you run and post the results?
ldd /opt/ryzom/ryzom_client | grep lua

It should be something like this
liblua5.2.so.0 => /usr/lib/x86_64-linux-gnu/liblua5.2.so.0 (0x00007f8de6b51000)
libluabind.so.0.9.1 => /usr/lib/libluabind.so.0.9.1 (0x00007f8de6934000)


Also to verify ryzom_client, could you run
md5sum /opt/ryzom/ryzom_client

and see if it matches
e5c60d198d52e9882d0595156ebc2f6c  /opt/ryzom/ryzom_client

---

Hello!

#33 [en] 

arumes@RMS-DESK:~$ ldd /opt/ryzom/ryzom_client | grep lua
    liblua5.1.so.0 => /usr/lib/x86_64-linux-gnu/liblua5.1.so.0 (0x00007f4bf3db3000)
    libluabind.so.0.9.1 => /usr/lib/libluabind.so.0.9.1 (0x00007f4bf3b96000)
    liblua5.2.so.0 => /usr/lib/x86_64-linux-gnu/liblua5.2.so.0 (0x00007f4bf07bd000)
arumes@RMS-DESK:~$ md5sum /opt/ryzom/ryzom_client

390718c47ede6e47a4ef8d665a1ac52c  /opt/ryzom/ryzom_client

So there's no match. For now, I'll just switch back to the previous version, because I think the problem lies with the PPA, not with my system. And now that I'm switching back, I notice that the version you mentioned is the 'old' version. The latest version for 14.04 is called 2.1.0.6447-0ubuntu1, so without the "~trusty1" at the end. Now that I reverted the upgrade, Ryzom is working again:


Could you take this up with the maintainer of the PPA? Seems like that's where the problem is.

Last edited by Sennuri (3 years ago)

#34 [en] 

I'm sorry, I just understood what happened :p

Canonical finally updated Ryzom from Ubuntu Software Center but they applied the wrong version for Ubuntu 14.04 :( So there is a conflict between the 2 versions.

For the moment, I suggest you to uninstall the one from Ubuntu Software Center and reinstall the one from the ryzom-isv PPA.

Since I could again talk to a Canonical employee, we'll be able to fix this problem :)

Thanks for discovering it :)

---

Kervala - Ryzom volunteer developer - Working on different clients

#35 [fr] 

Xiombarg
Canonical finally updated Ryzom from Ubuntu Software Center...

C'est une bonne nouvelle si ça bouge enfin chez Canonical.

---

Ducocinnio Nono, dit Duke Nono
Noble Matis, artisan de la maison noble La Firme
Gardien du Royaume et Béni de Jena

#36 [en] 

The problem that was happening is the following :

They applied the client for Precise (12.04) to all Ubuntu versions.

Under Precise, Ryzom was using Luabind linked against Lua 5.1, under Trusty Luabind is compiled against Lua 5.2.

So it tries to mix both Lua 5.1 and 5.2, which is creating these crashes :s

To fix your problem, I'm compiling new versions on PPA for Precise and Trusty (version 2.1.0.6449) with no changes in code but since version is greater, it shouldn't have conflicts anymore :)

Next step is to contact the Canonical Employee and explain to her that we are using dynamic linking and she shouldn't copy Precise package for all other Ubuntu versions.

---

Kervala - Ryzom volunteer developer - Working on different clients

#37 [fr] 

Dukenono
Xiombarg
Canonical finally updated Ryzom from Ubuntu Software Center...

C'est une bonne nouvelle si ça bouge enfin chez Canonical.

Oui, je suis plutôt content :) Même si ça a entrainé un effet secondaire :p Mais tout n'est pas perdu !

---

Kervala - Ryzom volunteer developer - Working on different clients

uiWebPrevious123uiWebNext
 
Last visit Tue Apr 23 00:01:14 2019 UTC
P_:

powered by ryzom-api