English French German Spanish Russian
Problème d'encodage dans les bulles - Web Apps - Foro de la Comunidad RyzomInicioInvitado

Web Apps


uiWebPrevious1uiWebNext

#1 [fr] 

Je fait en ce moment une app. Et je suis confrontée à un petit problème.



tous mes fichiers sont encodés en UTF-8 et la page est elle aussi définie en UTF-8.

#2 [fr] 

je te l'avais dit, les bulle sont forcé en iso on ne peux rien y faire.
C'est codé comme ça en dur dans le code de ryry.

D'ailleur ça me semble parfaitement stupide et j'aimerai bien connaitre la raison ^^

Última edición por Osquallo (6 years hace)

---

Osquallo
Les rêveries du yubo flaneur
The musings of the rambling yubo

#3 [fr] 

J'ai trouver un truc qui semble marcher : j'ai utilisé un autre fichier (avec include) qui lui est encodé en ANSI.

Par contre je pense que pour le russe c'est mort.

Última edición por Phaozhu (6 years hace)

#4 [fr] 

Ata Phaozhu,

alt="<?php echo iconv('UTF-8', 'MS-ANSI', 'Taki-Taki en Français avec accents éô...'); ?>"


Mata népuké

---

#5 [fr] 

Le problème des bulles est régler dans le prochain client la balise title étant implémenter :p

Et non sinon c'est hardcodé par une fonction qui force le alt en ISO ;p

Última edición por Osquallo (4 years hace)

---

Osquallo
Les rêveries du yubo flaneur
The musings of the rambling yubo

#6 [fr] 

et pourtant si....
c'est ce que j'utilise dans mon appli et ca marche !
peut etre que dans le nouveaux client.... a voir ;)

Última edición por Lapiaz (4 years hace)

---

#7 [en] 

for current client, you had to use utf8 text on webpage and iso-8859-1 (or such) on tooltips

new beta client will use full utf8 for page and tooltips (if page is not utf8, it tries to convert it). if new beta clients have such utf8 corruption, then its either invalid utf8 or client bug.

---

Hello!
uiWebPrevious1uiWebNext
 
Last visit jue 02 jul 2020 16:02:54 UTC UTC
P_:

powered by ryzom-api