English French German Spanish Russian
[BUG] Map offset is off when scrolling map in other view - Mutual Mac - Ryzom Community ForumHomeGuest

Mutual Mac


uiWebPrevious1uiWebNext

#1 [en] 

Hello, I just ran into that one. Never happened before, at least never pre-2.0.

Map default is to be centered on toon in current region.
I have a full-screen map in View 4 (F4) that I switch to when I need to locate a flag or teammates.
If I scroll the map in View 4, then revert to View 1, the map takes into account the changed offset, BUT does not update the visible map.
If I try to edit a flag in View 1, the first edit is fine, but the next edit selects the wrong one, an existing flag with a different name/title.
Resetting the map to be centered on toon does not reset this behavior.

I'll check later to see if it's reproductible.

EDIT: Switching regions does reset the bug.

Last edited by Hekla (7 years ago)

#2 [en] 

Topic moved

---

Sywindt | Game Master | EN, NL, de, fr

#3 [en] 

The bug with renaming flags also happens if you don't use a secondary desktop. It's pretty annoying because i already lost many new PR material flags. And some are pointing to the wrong place now (actually the flags are in the right place but they say something that was meant for another flag).

#4 [en] 

Hi Hekla,

I am not able to reproduce this on the Windows client. What OS are you using?

When I switch from desktop 4 to desktop 1, the desktop 1 map is exactly the same as it was before, and tooltips and renaming work as expected.

---

Sywindt | Game Master | EN, NL, de, fr

#5 [en] 

I was not able to reproduce it either, so it's likely to have been a random bug creating a discrepancy between image offset and flag offsets.

In general, a change in map zoom factor / offset in a particular view does change zoom factor / offset in all other views. I'm not sure if that caused the particular issue I was facing, but it would make sense for each view to preserve its own map settings, and only be reset upon region change when teleporting.

#6 [en] 

I got this bug almost every time i'm digging in wastelands. It might exist when i'm in different regions, but wastelands is where i do change flags frequently now. The annoying part is that the map ui reflects the flag selection with a highlight on the selected flag but does in fact change a different flag. This can mess up the whole mapping effort.

Temporary Workaround:

Go to world map (back arrow), then go back to the region you are in.

OS: Windows 7 32bit, offizieller und aktueller Client.

---

Casy * Foreign Secretary * Alliance of Honor
Intensive Care Bear

#7 [en] 

I have problems with the wrong flags being edited or deleted in GoC. I am on Ubuntu with 2.0 client. This bug is so annoying

---

#8 [en] 

I have this problem too.

#9 [en] 

Can somebody please post a dependable way to reproduce this? That would help immensely in solving the problem.

---

Sywindt | Game Master | EN, NL, de, fr
uiWebPrevious1uiWebNext
 
Last visit Wed Apr 8 01:54:18 2020 UTC
P_:

powered by ryzom-api