Mutual Mac


macOS 10.13.6 - Client crashes after login

Hello, all.

I freshly downloaded both the client from the Apple App Store and the one available from your website. Both of them crash shortly after login with pretty much the same error:


Process: Ryzom [1131]
Path: /Users/USER/Library/Application Support/Ryzom/*/Ryzom.app/Contents/MacOS/Ryzom
Identifier: com.winchgate.Ryzom
Version: 3.6.0 (3.6.0)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Ryzom [1131]
User ID: 501

Date/Time: 2020-06-27 17:33:29.986 +0200
OS Version: Mac OS X 10.13.6 (17G13035)
Report Version: 12
Anonymous UUID: 6613C888-5A24-587F-EC42-6D70734EEB80


Time Awake Since Boot: 4700 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x4] Symbol missing

Dyld Error Message:
Symbol not found: ____chkstk_darwin
Referenced from: /Users/USER/Library/Application Support/Ryzom/*/Ryzom.app/Contents/MacOS/Ryzom
Expected in: /usr/lib/libSystem.B.dylib


I'd appreciate any help you can give. Mind, this is a Hackintosh, but I have no issues running a wide variety of other games, including EVE Online, World of Warcraft, TESO, even TOR under WINE.

Weirdly, the Apple App Store client works fine on my 2017 MacBook under Catalina.

Thank you for your assistance.

PS: I've tried to attach the client.log file, but there seems to be no way to do so. Let me know if you need it. There were a bunch of warnings in there, but no outright errors.
Show topic
Last visit Tuesday, 5 March 14:11:42 UTC
P_:

powered by ryzom-api