Mutual GNU / Linux


Ryzom FV 2.1.0.6447 fails to start

The problem that was happening is the following :

They applied the client for Precise (12.04) to all Ubuntu versions.

Under Precise, Ryzom was using Luabind linked against Lua 5.1, under Trusty Luabind is compiled against Lua 5.2.

So it tries to mix both Lua 5.1 and 5.2, which is creating these crashes :s

To fix your problem, I'm compiling new versions on PPA for Precise and Trusty (version 2.1.0.6449) with no changes in code but since version is greater, it shouldn't have conflicts anymore :)

Next step is to contact the Canonical Employee and explain to her that we are using dynamic linking and she shouldn't copy Precise package for all other Ubuntu versions.

---

Kervala - Ryzom volunteer developer - Working on different clients

Show topic
Last visit Fri Nov 27 11:54:31 2020 UTC
P_:

powered by ryzom-api